Current time: 12-07-2019, 04:11 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
browser level settings in Wptdrivier.ini are being ignored
08-02-2016, 07:01 PM (This post was last modified: 08-02-2016 07:09 PM by kkumar86@gmail.com.)
Post: #1
browser level settings in Wptdrivier.ini are being ignored
WIth the latest wptdriver update, it seems that the browser specific settings are being ignored when launching the tests. Please help, the update on Aug 1st seems to be the culprit.

Example of INI FILE

[WebPagetest]
ec2=1
browser=Chrome
Time Limit=120
software=http://www.webpagetest.org/installers/software.dat

[Chrome]
exe="%PROGRAM_FILES%\Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'
installer=http://www.webpagetest.org/installers/browsers/chrome.dat

[Chrome1]
exe="%PROGRAM_FILES%\Google\Chrome\Application\chrome.exe"
options=' --load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server --no-default-browser-check'
installer=http://www.webpagetest.org/installers/browsers/chrome.dat

Tests get launched with following Chrome settings

https://gist.github.com/anonymous/9c032b...1b710326bc

Note the executable path (It has ChromeSxS).
Find all posts by this user
Quote this message in a reply
08-03-2016, 12:23 AM
Post: #2
RE: browser level settings in Wptdrivier.ini are being ignored
The Chrome SxS is intentional and shouldn't cause problems. It is a symlink path to the real chrome directory that is a hack that causes Chrome to not show the "developer mode" extension warning dialog that launched with 52.

Is it safe to assume that the issue is that "Chrome1" isn't launching with the additional flags (perhaps others than you list because I'm pretty use --no-default-browser-check is tacked on automatically)?

I made a change over the weekend to ignore the "options" entry and always populate the --load-extension and --user-data-dir options automatically because it was a common thing that people were messing up.

If you need additional flags or want to change the proxy flag you can specify a "command-line" entry in the ini that will add the additional flags.

Code:
[WebPagetest]
ec2=1
browser=Chrome
Time Limit=120
software=http://www.webpagetest.org/installers/software.dat

[Chrome]
exe="%PROGRAM_FILES%\Google\Chrome\Application\chrome.exe"
installer=http://www.webpagetest.org/installers/browsers/chrome.dat

[Chrome1]
exe="%PROGRAM_FILES%\Google\Chrome\Application\chrome.exe"
command-line=--no-proxy-server --no-default-browser-check'
installer=http://www.webpagetest.org/installers/browsers/chrome.dat

If command-line is specified then --no-proxy-server will be omitted from the default command-line and whatever you provide will be included in it's place.

If it is causing too much pain or you really need to point the user data dir to a different folder I can revert the change but making those two settings non-breakable fixes a good number of issues that people have had when configuring the ini files.
Visit this user's website Find all posts by this user
Quote this message in a reply
08-03-2016, 04:28 AM (This post was last modified: 08-03-2016 04:34 AM by kkumar86@gmail.com.)
Post: #3
RE: browser level settings in Wptdrivier.ini are being ignored
thanks for quick response.

Could one specify --load-extension=path_to_unpacked_extenion in the command-line settings?

Patrick, requirement is just to be able to provide additional extensions using

--load-extension=<wpt_extension>,<additional_extensions>
Find all posts by this user
Quote this message in a reply
08-05-2016, 02:09 AM
Post: #4
RE: browser level settings in Wptdrivier.ini are being ignored
It might work if you specify the same command-line option again with the additional extensions. I haven't tried it. If not I can also provide another entry that lets you specify additional extensions.
Visit this user's website Find all posts by this user
Quote this message in a reply
08-19-2016, 04:54 AM
Post: #5
RE: browser level settings in Wptdrivier.ini are being ignored
(08-05-2016 02:09 AM)pmeenan Wrote:  It might work if you specify the same command-line option again with the additional extensions. I haven't tried it. If not I can also provide another entry that lets you specify additional extensions.

Hi Patrick.

I have been trying this and I believe that trying to load additional extensions in this manner causes some gaps in the waterfall charts when the extension loads. Before the change, I was able to load an adblocking extension without seeing the gaps.

Would that be the cause, or is there something else that maybe causing the issue? Let me know if you need additional details.
Find all posts by this user
Quote this message in a reply
09-07-2016, 04:59 AM
Post: #6
RE: browser level settings in Wptdrivier.ini are being ignored
Thanks Patrick. Yes it did work.

Karan
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)