Current time: 12-14-2017, 02:23 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FireFox Fails to Test on Private Instance
11-10-2016, 01:23 AM
Post: #1
FireFox Fails to Test on Private Instance
Patrick - We are running a private instance of WPT and we noticed that it stoped getting test results from Firefox. The test complete with a failure, no data is collected.

I have gone through the config files wptdriver, locations and settings to ensure that we have Firefox configured properly. I have updated Firefox and WPT but that did not seem to fix the problem.

When I queue up a test I can see that the networking is correct the FF page loads but the URL reads 127.0.0.1:8888/blank.html. I included a pic sorry for the quality but the blank html page will show until the job times out, which I have set at 45sec.

Have you seen this before ? or can you point me in the right direction?

Note: Chrome and mobile are working everything gets sent to Jenkins then to Graphana.
Find all posts by this user
Quote this message in a reply
11-12-2016, 09:09 AM
Post: #2
RE: FireFox Fails to Test on Private Instance
What version of the agent? You need a fairly recent build as Firefox breaks from time to time as things change.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-15-2016, 07:34 AM
Post: #3
RE: FireFox Fails to Test on Private Instance
(11-12-2016 09:09 AM)pmeenan Wrote:  What version of the agent? You need a fairly recent build as Firefox breaks from time to time as things change.

I am using WebPageTest 2.18. This appears to be the newest version.
Find all posts by this user
Quote this message in a reply
11-16-2016, 07:25 AM
Post: #4
RE: FireFox Fails to Test on Private Instance
Check your /getTesters.php page which will list the agent versions: http://www.webpagetest.org/getTesters.php?f=html

The agent can update independently of the web server and there have been a lot of updates since the 2.18 release: https://sites.google.com/a/webpagetest.o...est-Agents

If you are ok with getting automatic updates for the agents there is a setting in settings.ini on the server that will fetch them automatically: https://github.com/WPO-Foundation/webpag...ample#L117
Visit this user's website Find all posts by this user
Quote this message in a reply
11-17-2016, 07:49 AM (This post was last modified: 11-17-2016 07:50 AM by jmcclure.)
Post: #5
RE: FireFox Fails to Test on Private Instance
Adding the auto update worked great ! Thanks for your help.
Find all posts by this user
Quote this message in a reply
Yesterday, 05:23 AM
Post: #6
RE: FireFox Fails to Test on Private Instance
(11-17-2016 07:49 AM)jmcclure Wrote:  Adding the auto update worked great ! Thanks for your help.

This solution did not worked in our WPT 2.18 private instance, have been trying different versions of WPT(2.18,2.19,3.0 and 17.08). None of them works in either proxy environment or non-proxy environment, Need some suggestions Sad
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)