Current time: 12-11-2017, 05:43 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error given multiple times on specific website
11-17-2016, 08:02 PM
Post: #1
Error given multiple times on specific website
Hi,

The following test for the same website all give Web Page Test errors. Think I have found a bug.


https://www.webpagetest.org/result/161117_PR_3N6Q/
https://www.webpagetest.org/result/161117_1M_2A6D/
https://www.webpagetest.org/result/161116_R3_BN10/
Find all posts by this user
Quote this message in a reply
11-22-2016, 12:21 AM
Post: #2
RE: Error given multiple times on specific website
Try turning on the "preserve user agent string" field in the advanced settings. Looks like the security for that site may be turned up pretty tight and it is probably blocking access based of the PTST/ string that gets added to the UA string (or it could be blocking access from the IP addresses).

Not a bug with WPT itself, the site is actively blocking access which is what 403's usually are.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-28-2016, 08:26 PM
Post: #3
RE: Error given multiple times on specific website
Hi Patrick,

The keepua (preserve user agent string) seemed to fix it. What actually does it do? Would there be any benefit/issues with turning this on for all tests?
Find all posts by this user
Quote this message in a reply
11-28-2016, 10:48 PM
Post: #4
RE: Error given multiple times on specific website
It prevents WPT from appending a PTST/<version> number to the UA string and uses the browser's original string. Leaving the PTST addition makes it possible to filter out test traffic in your analytics so I usually wouldn't recommend always disabling it.
Visit this user's website Find all posts by this user
Quote this message in a reply
12-02-2016, 09:41 PM
Post: #5
RE: Error given multiple times on specific website
When calling WPT via url, if enable the keepua=1 querystring attribute, the keepua is not passed to WPT.

See example below:
https://www.webpagetest.org/runtest.php?...n.co.uk&k=[KEY HERE]&f=json&location=ec2-eu-west-1%3AChrome&runs=3&video=1&fvonly=0&keepua=1

Is this a bug?
Find all posts by this user
Quote this message in a reply
12-02-2016, 11:58 PM
Post: #6
RE: Error given multiple times on specific website
Does the same test work through the UI? The UI uses the same API so it would be strange to work on one cease but not the other.
Visit this user's website Find all posts by this user
Quote this message in a reply
12-03-2016, 01:00 AM (This post was last modified: 12-03-2016 01:06 AM by spencer_shaw.)
Post: #7
RE: Error given multiple times on specific website
If appending keepua=1 to the querystring is the same as selecting "preserve user agent string" then the test works through the UI but not via the querystring. I think there could be a bug.
Find all posts by this user
Quote this message in a reply
12-12-2016, 09:56 AM
Post: #8
RE: Error given multiple times on specific website
Think this may be an issue to do with where the tests are running. Preserve User Agent works in London but not Ireland. Created a new thread for this now:

https://www.webpagetest.org/forums/showt...?tid=14647
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)