Current time: 12-14-2017, 06:57 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WPT Agent (ami-4a84a220) work request not seen on WPT server using SSL connection
12-06-2016, 09:47 AM (This post was last modified: 12-07-2016 04:21 AM by vaghanwa.)
Post: #1
WPT Agent (ami-4a84a220) work request not seen on WPT server using SSL connection
1. I have configured WPT server in AWS (ami-fcfd6194). I have configured nginx to use SSL (self-signed cert).
2. WPT server sits behind load balancer. I have installed CA signed certs on load balancer.
3. THe location.ini for server is as follows:
[locations]
1=Virginia-Agent
default=Virginia-Agent

[Virginia-Agent]
1=Virginia
label="Virginia agent"
default=Virginia

[Virginia]
browser=IE 11,Chrome,Firefox,Safari

4. Currently there is only one WPT server instance behind this LB
5. From a rest client I send a Test run request to WPT server. I see the request in the server logs and request sits in a queue with response
"statusCode": 101,
"statusText": "Waiting at the front of the queue...",

6. I configured WPT agent (ami-4a84a220) with user data
wpt_server=<hostname matching cert> wpt_loc=Virginia wpt_validcertificate=1
7. I dont see any polling work requests in the server logs. Neither am I seeing agent take on any work and requests\work being completed
8. I have tried changing user_data to wpt_validcertificate=0 and also removing it, but it still does not work
9. How do we turn on logging for wpt_driver? I dont see any logs for wpt_driver
10. We tried updating agent to latest but we get "Problem loading, trying to load settings" message
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)