Current time: 12-16-2017, 10:51 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fast page considerably slower since mid Dec
02-03-2017, 09:13 PM
Post: #1
Fast page considerably slower since mid Dec
One of the sites that I monitor that was fairly quick previously has seen very intermittent speeds since mid December. We're using SpeedCurve (which uses Web Page Test).

As you can see in the attached image - from mid December both Firefox and iPhone took a big hit in speed. Our Devs don't know of any code or server changes that could have caused this.

Here are two examples of slow tests (1 firefox and 1 iphone)

Firefox - https://wpt.speedcurve.com/result/170202...95b6241dc/

iPhone - https://wpt.speedcurve.com/result/170202...3caea7ab5/

Any help would be hugely appreciated.


Attached File(s) Image(s)
   
Find all posts by this user
Quote this message in a reply
02-04-2017, 03:34 AM
Post: #2
RE: Fast page considerably slower since mid Dec
The Firefox test has both fast and slow cases in the same test so it's sort of possible to see what is happening but it doesn't look like it is content related. The browser seems to go out to lunch between completing the TLS negotiation and fetching the resource. Hard to say if it is a machine issue or something going on with cert validation but whatever is happening looks to be local to the machine and not server related.

Do you have a "good" test result for the iPhone case? All 3 runs in the test you had looked like they had similar performance with no obvious gaps so I'd need something to compare it to to see what changed.
Visit this user's website Find all posts by this user
Quote this message in a reply
02-04-2017, 06:10 AM (This post was last modified: 02-04-2017 06:15 AM by andydavies.)
Post: #3
RE: Fast page considerably slower since mid Dec
I've noticed that some time in the last month or so Chrome's started doing OCSP checks on EV certs (or at least they're showing up in the waterfalls) and I'm seeing this push some waterfalls out.

I'm not sure whether I've just seen the increased OCSP checks for Symantec signed certs or for other CAs too.

As the iPhone is really Chrome, could that be the source of the change here?

Andy

Using WebPageTest - http://usingwpt.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
02-04-2017, 07:05 AM
Post: #4
RE: Fast page considerably slower since mid Dec
I'd expect to see the underlying requests for OCSP checks but if it is doing more validation of some kind locally those wouldn't show up.
Visit this user's website Find all posts by this user
Quote this message in a reply
02-06-2017, 08:36 PM
Post: #5
RE: Fast page considerably slower since mid Dec
Patrick / Andy - Many thanks for your responses

Here is a fast iPhone test before the tests slowed down - https://wpt.speedcurve.com/result/161210...6048579d5/

When you say the Firefox tests seems machine related and not server related do you mean that is likely the test machine that has an issue and not the webserver? I've seen similar tests on more than one machine running WebPageTest.
Find all posts by this user
Quote this message in a reply
02-06-2017, 11:48 PM
Post: #6
RE: Fast page considerably slower since mid Dec
In the iPhone case the change is due to the HTTPS negotiation for the base page now doing OCSP validation checks where it wasn't before (which is what Andy mentioned also). Here are the two tests next to each other: https://wpt.speedcurve.com/video/compare...0&end=full

Did you recently move to an EV Certificate where you weren't using one before or were you possibly using OCSP Stapling before and are no longer? The current certificate is definitely EV and it looks like the certificate itself was issued close to a year ago so I'd be more inclined to think it was server config issues with stapling: https://www.ssllabs.com/ssltest/analyze....175&latest

Unfortunately I can't see if the old tests had stapled certificates.

Firefox in theory could be the same or a similar issue because the delay is also right where certificates would be validated but I'd expect to see the certificate checks if that were the case (like we see with iPhone). If you can reproduce the Firefox slowness with tcpdump enabled (either on the public instance or on Speed Curve) then that would prove for sure one way or another.

As far as it being something on the machine, it could just be some decisions the browser is making but usually when there are big gaps with no CPU and no Bandwidth it is a machine issue but certificate validations if they aren't exposed in the waterfall could also cause the same behavior.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)