Current time: 12-17-2017, 11:36 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is there a size limit when importing ?
03-24-2017, 01:37 AM
Post: #1
Is there a size limit when importing ?
HI,

I have setup my own private instance and followed Michael Klepikov's demo to setup automatically importing performance data at the end of my Selenium tests. Now if the tests are around 3 minutes or less I have no problems and everything works a treat but if they are more, sometimes I have tests lasting 4 - 5 mins then all I see is

"First View: Test Data Missing"

When viewing the imported report, I don't receive any errors during the import and it appears to have worked correctly except the data is missing.

Any ideas?

Thanks
Steve
Find all posts by this user
Quote this message in a reply
03-24-2017, 07:16 PM
Post: #2
RE: Is there a size limit when importing ?
The WebPagetest agent is probably trying to upload too large files - over the default limit. See this troubleshooting guide which says "Change upload_max_filesize and post_max_filesize to larger values in php.ini." for the server config. If you are using nginx, the setting is client_max_body_size, for example:
Code:
client_max_body_size = 10M;

If this doesn't fix the issue, you can still take a look at the server logs for clues. Are you trying to run a scripted test?
Find all posts by this user
Quote this message in a reply
03-25-2017, 02:00 AM
Post: #3
Thumbs Up RE: Is there a size limit when importing ?
(03-24-2017 07:16 PM)sertovs Wrote:  The WebPagetest agent is probably trying to upload too large files - over the default limit. See this troubleshooting guide which says "Change upload_max_filesize and post_max_filesize to larger values in php.ini." for the server config. If you are using nginx, the setting is client_max_body_size, for example:
Code:
client_max_body_size = 10M;

If this doesn't fix the issue, you can still take a look at the server logs for clues. Are you trying to run a scripted test?

Thanks I think that was it, I had updated the size limit in the nginx.conf but not php.ini.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)