Current time: 12-19-2017, 06:13 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Performance review" and "Processing breakdown" missing
03-31-2017, 04:18 PM
Post: #1
"Performance review" and "Processing breakdown" missing
I've set up a private instance using WebPageTest-3.0 and wptagent, both running on Ubuntu Linux 16.04.

It works fine, however, in test results, "Performance review" and "Processing breakdown" are missing.

http://localhost/install/ shows everything is installed except APC (since it's using PHP 7, there is no APC) and Python SSIM - but I guess they shouldn't matter for "Performance review" and "Processing breakdown".


Did I miss anything during the installation? Or perhaps wptagent does not support these yet?
Find all posts by this user
Quote this message in a reply
03-31-2017, 10:48 PM
Post: #2
RE: "Performance review" and "Processing breakdown" missing
The agents support everything the Windows agents do (minus a few script commands).

For processing breakdown, it's just that you need to enable timeline capture (chrome tab of advanced settings).

For Performance review (and to get HTTP/2 request details) you need to pull the latest server code from github. There were some server changes post-3.0 to handle some additional artifacts from the agents to be able to report those.

As far as apc goes, you can still configure apcu which will help for high-volume installs (some things get memory cached) but otherwise doesn't matter much.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-31-2017, 10:58 PM
Post: #3
RE: "Performance review" and "Processing breakdown" missing
(03-31-2017 10:48 PM)pmeenan Wrote:  The agents support everything the Windows agents do (minus a few script commands).

For processing breakdown, it's just that you need to enable timeline capture (chrome tab of advanced settings).

Thanks, it works!

"Capture Dev Tools Timeline" - is there a setting to make it selected by default?
Find all posts by this user
Quote this message in a reply
03-31-2017, 11:05 PM
Post: #4
RE: "Performance review" and "Processing breakdown" missing
Not currently. Newer releases should (hopefully) remember the setting on a per-user basis and it may be enabled by default on the latest code (can't remember off the top of my head).
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)