Current time: 12-17-2017, 02:45 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tests contain requests with User-Agent Microsoft-CryptoAPI
04-25-2017, 07:32 PM
Post: #1
Tests contain requests with User-Agent Microsoft-CryptoAPI
Hello all,

eventually some web page tests contain requests with
User-Agent: Microsoft-CryptoAPI/6.1
Host: gm.symcd.com

even though the tests are run with user agent Chrome and the original webpage does not contain any links to the aforementioned host.

Example: https://www.webpagetest.org/result/17042...view_step1
Request #2

Re-running the same tests usually results in a run without any of those requests.

This happens on http://www.webpagetest.org as well as on our local WPT installation.
I suspect Microsoft Windows Update agent to be the culprit.

These requests should not happen during a WPT test run.

Best regards,
Ingo Steinke
Find all posts by this user
Quote this message in a reply
04-25-2017, 10:39 PM
Post: #2
RE: Tests contain requests with User-Agent Microsoft-CryptoAPI
Those are OCSP validation checks for http://www.weltbild.de and are absolutely part of the test. The only reason they don't show up all the time is that the validation check result will be cached for a while.

If you want to see it always show up, there is a checkbox on the advanced settings page to clear the OS certificate cache for every run. That will also cause OCSP checks for intermediate certificates though which are usually in the cache.

The performance fix to make them not happen is to enable OCSP Stapling on the web server: https://hpbn.co/transport-layer-security...p-stapling
Visit this user's website Find all posts by this user
Quote this message in a reply
05-04-2017, 07:42 PM
Post: #3
RE: Tests contain requests with User-Agent Microsoft-CryptoAPI
Thanks for the explanation!
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)