Current time: 12-18-2017, 07:39 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WPT ConsoleLog does not match local Chrome Console Log
09-17-2017, 11:45 AM
Post: #1
WPT ConsoleLog does not match local Chrome Console Log
Background ... Chrome is alerting users when they browse a website that is collecting a password or credit card & the website is not secure with HTTPS.

There is a website I'm testing on my local, I get this warning in the address bar "Not Secure" and in the console:

> This page includes a password or credit card input in a non-secure context. A warning has been added to the URL bar. For more information, see https://goo.gl/zmWq3m.

However, when I run the website in WPT, the consoleLog does not report this warning. It's reporting some other warnings, but not the security warning.

In WPT I checked the console log under the screenshot. And I also did an api call and the response 'consoleLog' does not have the security warning.

https://www.webpagetest.org/result/17091...reen_shot/

Ideas or suggestions?

Thanks!


Attached File(s) Image(s)
   
Find all posts by this user
Quote this message in a reply
09-25-2017, 04:15 PM
Post: #2
RE: WPT ConsoleLog does not match local Chrome Console Log
Update. Is it possible Chrome on the test agent has console logs set to "errors" only? The message i'm looking for is an "alert" so maybe that's why it's not being displayed?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)