Current time: 12-11-2017, 07:36 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Suddenly no first view and missing result history
10-25-2017, 02:09 AM
Post: #1
Suddenly no first view and missing result history
Hi over there.

Actually I'm struggling with a very sudden and showstopping issue with our private instance.

Last friday I updated our docker image from OSM. While doing this I used the opportunity to cleanly reboot the WPT server (private instance on Debian Stretch w/ PHP7) and it's agents (KVM Windows 7 with wptdriver). We're using the latest 3.x release of WPT (even though it's now 'old', I'm actually planning to upgrade till next year..).

That said, I really didn't change anything on the WPT side except reboot. Since then, alle the tests that are triggered through OSM run through fine.

However, today I realized that alle the tests that went through since friday (reboot) do not show up in the result history of WPT. But when I live-view a test-process that was just triggered by OSM I get an result that shows only repeated view - first view data "is missing". This is what initially led me to check WPT itself, because OSM showed that alle tests completed fine but didn't show any first view results for them (no data since friday).

All r/w permissions on the server are still fine, test.log says nothing to complain about (see below) and /install page lists everything as OK.

Is it possible, that wptdriver got an update because of the reboot? It is set to update automatically and this was the first reboot for about two months or so. I didn't found something on github related to this (changes to wptdriver or something).

Any clues?

test.log:
Code:
2017/10/24 15:00:01 - Test Created
2017/10/24 15:05:29 - Starting test (initiated by tester WPTAGENT02-XXX.XXX.XXX.XXX)
2017/10/24 15:07:15 - Test Run Complete. Run: 1, Cached: 1, Done: 1, Tester: WPTAGENT02-XXX.XXX.XXX.XXX
2017/10/24 15:07:15 - Test Complete

One thing did irritate me. All test-results BEFORE the reboot last friday were zipped in a package under the corresponding date folders with a filename like 'A1', 'B8', 'ZA' and so on. WPTs convention of file handling. Now, every test-result after the reboot is handled in the same folder-date-convention, but with a filename like 'ads7865a87sfd8', I guess this is a kind of job UUID or something. May this be relevant?

Thanks in advance,
R.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)