Current time: 09-23-2019, 12:12 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Random failures from Taiwan WPT instance
07-27-2018, 07:59 PM (This post was last modified: 07-27-2018 08:04 PM by jakub.)
Post: #4
RE: Random failures from Taiwan WPT instance
Hi Patrick, thanks for you input and the pcap suggestion!

Some things I forgot to mention / did not emphasise enough:

- the issues happen both for static and dynamic resources, I just used a static JSON URL for simplicity
- the IP from the WPT logs is 195.8.215.136 which is the expected IP for the domain, resolved in the same way from everywhere (it's not geodistributed / not a CDN)
- the issue happens both for http and https requests with equal chance
- so far I only reproduced on WPT Taiwan instance, not others (that's a bit weird honestly)

My reasoning is: since the IP matches, and issue happens for HTTPS request, and there's no MitM etc. (hence the integrity is guaranteed, no third-party proxies messing with the output), the problem indeed must be on the server side (maybe some anti-bot solution as you mentioned).

This is an interesting run where the initial http request is fine (redirects to https) but https gets 503 response:
https://www.webpagetest.org/result/18072...1_request2
pcap is here:
https://www.webpagetest.org/getgzip.php?...file=2.cap

I checked the PCAP for the https request and it looks like it contains the proper cert etc.

I will check with the devops again. Thanks!
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: Random failures from Taiwan WPT instance - jakub - 07-27-2018 07:59 PM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)