Current time: 08-05-2020, 09:36 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
--shaper none option does not work
07-31-2020, 02:22 AM
Post: #1
--shaper none option does not work
Hi,
Was trying to use the "--shaper none" option when starting my Dockerized agent, but getting an error:

docker run -d -vvv -p 4001:80 --network="host" --shaper none -e "SERVER_URL=http://localhost:4000/work/" -e "LOCATION=Test" webpagetest/agent

unknown flag: --shaper

Am I missing anything?

Thanks,
Tim
Find all posts by this user
Quote this message in a reply
08-01-2020, 02:37 AM
Post: #2
RE: --shaper none option does not work
Hi Tim!

--shaper is a parameter of wptagent, not of docker, so it should be added to the EXTRA_ARGS environment variable inside the docker -e option, so it gets passed to wptagent at startup. For example:

Code:
docker run -d -vvv -p 4001:80 --network="host" -e "SERVER_URL=http://localhost:4000/work/" -e "LOCATION=Test" -e "EXTRA_ARGS=--shaper none" webpagetest/agent

I hope that it helps!
Find all posts by this user
Quote this message in a reply
08-01-2020, 07:03 AM
Post: #3
RE: --shaper none option does not work
Thanks very much, that worked.

Tim
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)