Current time: 12-18-2017, 01:22 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
403 Forbidden at localhost
03-31-2010, 07:20 AM
Post: #1
403 Forbidden at localhost
Hi,
I have completed the setup for WebPageTest. Apache and PHP are installed as per instructions given in readme.html.

When I try to access http://localhost, I get:

403 Forbidden
Forbidden

You don't have permission to access / on this server
.

Can anyone help? Here is a snippet from Apache error.log:

[Tue Mar 30 22:08:01 2010] [notice] Child 3920: Starting thread to listen on port 80.
[Tue Mar 30 22:08:10 2010] [error] [client 127.0.0.1] client denied by server configuration: C:/Program Files/WebPageTest/Web Site/content/runtest.php
[Tue Mar 30 22:17:19 2010] [error] [client 127.0.0.1] client denied by server configuration: C:/Program Files/WebPageTest/Web Site/content/
[Tue Mar 30 22:17:22 2010] [error] [client 127.0.0.1] client denied by server configuration: C:/Program Files/WebPageTest/Web Site/content/


And access.log contains:

127.0.0.1 - - [30/Mar/2010:22:07:38 +0100] "GET /runtest.php?url=www.aol.com HTTP/1.1" 403 213
127.0.0.1 - - [30/Mar/2010:22:08:10 +0100] "GET /runtest.php?url=www.aol.com HTTP/1.1" 403 213
127.0.0.1 - - [30/Mar/2010:22:17:19 +0100] "GET / HTTP/1.1" 403 202
127.0.0.1 - - [30/Mar/2010:22:17:22 +0100] "GET / HTTP/1.1" 403 202


Any help much appreciated!

Martin
Find all posts by this user
Quote this message in a reply
03-31-2010, 08:39 AM
Post: #2
RE: 403 Forbidden at localhost
Are you using the default .htaccess file? What does your httpd.conf look like (do you have AllowOverride enabled?) Looks like a problem with the apache config.
Visit this user's website Find all posts by this user
Quote this message in a reply
04-11-2010, 12:44 AM
Post: #3
RE: 403 Forbidden at localhost
(03-31-2010 08:39 AM)pmeenan Wrote:  Are you using the default .htaccess file? What does your httpd.conf look like (do you have AllowOverride enabled?) Looks like a problem with the apache config.

Thanks for your response Pat. I am using the default htaccess file (have not changed it). However I had made a mistake when updating the httpd.conf file: When installing WebPageTest, I put it here:
C:/Program Files/WebPageTest. Therefore I needed to update the httpd.conf file (provided by yourslelf) so that all references to WebPageTest pointed to that location. This is did, but unfortunately I missed a few! <shrug>

I've now corrected this and all working fine!

Thanks very much for your help.

Martin
Find all posts by this user
Quote this message in a reply
01-03-2013, 09:24 AM
Post: #4
Sad RE: 403 Forbidden at localhost
Hi

I followed Andy Davies step-by-step guide http://andydavies.me/blog/2012/09/18/how...-instance/ to setup the configuration.

Here is my code:

locations.ini

[locations]
1=Local
default=Local

;
; These are the top-level locations that are listed in the location dropdown
; Each one points to one or more browser configurations
;

[Local]
1=Local-URLBlast
2=Local-WPTDriver
label=Local

;
; These are the browser-specific configurations that match the configurations
; defined in the top-level locations. Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)
;

[Local-URLBlast]
browser=IE 9
latency=0
label="Local - IE 9"
;browserExe=pagetest.exe
;key=TestKey123

;
; For a wptdriver configuration (chrome, firefox), the browser labels here
; MUST match the labels used in wptdriver.ini
;

[Local-WPTDriver]
browser=Chrome,Firefox
label="Local"


urlBlast.ini

[Configuration]
Startup Delay=30
Log File=c:\webpagetest\agent\urlblast
Timeout=120
use current account=1

; Where to get work from
Url Files Url=http://127.0.0.1/work/
Location=Local-URLBlast
browser=pagetest.exe
;Location Key=TestKey123

wptdriver.ini

[WebPagetest]
url=http://127.0.0.1/
location=Local-WPTDriver
browser=Chrome
;key=TestKey123
;Automatically install and update support software (Flash, Silverlight, etc)
software=http://www.webpagetest.org/installers/software.dat

[Chrome]
exe="C:\Program Files (x86)Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'
installer=http://www.webpagetest.org/installers/browsers/chrome.dat

[Firefox]
exe="C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
options='-profile "%PROFILE%" -no-remote'
installer=http://www.webpagetest.org/installers/browsers/firefox.dat
template=firefox

[Safari]
exe="%PROGRAM_FILES%\Safari\Safari.exe"

I have installed the DUMMYNET ipfw driver and started testmode.cmd too.

when i am starting urlBlast.exe,, i get installation failed....It keeps trying to install. And wptdriver.exe is clicked ,, small window opens and shows cpu usage etc...but no change in it as such...
when i trying to open http:L//127.0.0.1..i get Forbidden 403...
Can someone help me in this?

Thanks in advance
Keerthika
Find all posts by this user
Quote this message in a reply
01-04-2013, 06:12 AM
Post: #5
RE: 403 Forbidden at localhost
I think you must have urlblast and wptdriver mixed up. urlblast displays the CPU usage and wptdriver does the software install.

You can bypass the software installs by commenting out the "installer=" and "software=" lines in wptdriver.ini.

As far as the forbidden when navigating to http://127.0.0.1, is your apache running? Does the apache user have permission to read from the directory where the website code is?
Visit this user's website Find all posts by this user
Quote this message in a reply
01-04-2013, 06:27 AM
Post: #6
Sad RE: 403 Forbidden at localhost
(01-04-2013 06:12 AM)pmeenan Wrote:  I think you must have urlblast and wptdriver mixed up. urlblast displays the CPU usage and wptdriver does the software install.

You can bypass the software installs by commenting out the "installer=" and "software=" lines in wptdriver.ini.

As far as the forbidden when navigating to http://127.0.0.1, is your apache running? Does the apache user have permission to read from the directory where the website code is?

Sorry, for mixing it up..I have commented out those lines from wptdriver.ini.

yes, the Apache user has permission to read from the directory where the website code is.

In my office network,, they dont allow me to set dummynet...so i have skipped that part too....And i am using 2.9 version of webpagetest. My machine is Windows 7 Enterprise Edition with 64 bit OS.
Please help me to configure webpagetest.

Thank you
Keerthika
Find all posts by this user
Quote this message in a reply
01-07-2013, 11:37 PM
Post: #7
RE: 403 Forbidden at localhost
Your first step is to get Apache working so that you aren't gettign teh 403 errors and that's completely independent of the webpagetest configuration and settings.

Can you look at your apache error log and see if anything in there indicates why you might be getting errors?
Visit this user's website Find all posts by this user
Quote this message in a reply
01-08-2013, 05:32 AM
Post: #8
RE: 403 Forbidden at localhost
(01-07-2013 11:37 PM)pmeenan Wrote:  Your first step is to get Apache working so that you aren't gettign teh 403 errors and that's completely independent of the webpagetest configuration and settings.

Can you look at your apache error log and see if anything in there indicates why you might be getting errors?

Apache and php version crashed each other. I have resolved it.
Now my problem is i dont get any results. I get
"The test completed but there were no successful results."
I am running WebpageTest server and agent on the same machine Windows 7 prof. I have used 2.9 webpagetest.
Find all posts by this user
Quote this message in a reply
01-08-2013, 05:56 AM
Post: #9
RE: 403 Forbidden at localhost
That is probably because of dummynet. Your locations.ini needs to be modified to specify connectivity=...

Code:
[Local-URLBlast]
browser=IE 9
latency=0
label="Local - IE 9"
connectivity=LAN

[Local-WPTDriver]
browser=Chrome,Firefox
label="Local"
connectivity=LAN

That is needed so that WPT doesn't attempt to use IPFW for traffic shaping.
Visit this user's website Find all posts by this user
Quote this message in a reply
01-08-2013, 06:26 AM
Post: #10
RE: 403 Forbidden at localhost
I have changed locations.ini but still i get the same result. But i can see some changes in the URLBLast log file:

Browser Launched Cleared Cache-Run_1!http://google.com
Browser Lauched Cached-Run_1^http://google.com
.....
i dont know how to resolve this.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)