Current time: 12-12-2017, 03:15 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Keep-Alive showing as not enabled but as far as i know it is
12-07-2011, 04:36 AM
Post: #11
RE: Keep-Alive showing as not enabled but as far as i know it is
I'd revert your httpd.conf back to:

Code:
BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0

That is the official version of it from Apache that targets JUST the broken version of MSIE and it is safe to do (even better would be to remove it entirely because you will never see IE 4 beta 2 in the wild).

I assume the only other match which is in ssl.conf is the entry you put in there and is the SetEnvIf matching. From reading here: http://blogs.msdn.com/b/ieinternals/arch...-slow.aspx I'd recommend removing that entirely as well unless you feel really dtrongly about supporting pre-IE6 IE browsers (and if so I assume a LOT of other stuff on your site would be broken).
Visit this user's website Find all posts by this user
Quote this message in a reply
12-07-2011, 04:50 AM (This post was last modified: 12-07-2011 05:17 AM by gfm.)
Post: #12
RE: Keep-Alive showing as not enabled but as far as i know it is
FYI: In the is file conf.d/ssl.conf here is what I did, but obviously it still isn't correct:

#SetEnvIf User-Agent ".*MSIE.*" \
# nokeepalive ssl-unclean-shutdown \
# downgrade-1.0 force-response-1.0
#
SetEnvIf User-Agent ".*MSIE [1-5].*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0
SetEnvIf User-Agent ".*MSIE [6-99].*" \
ssl-unclean-shutdown
ok...I just read your comments and I've been operating on the premise that the older code in my config files is outdated, and it needs to be updated to newer, better code, rather than deleted. If it is fine to just remove all this I could do that instead. So should I just comment out any lines that have to do with downgrading the browser response...all those found by my grep? I am assuming that I won't see any drastic, unintended consequences by doing that...
To make sure I don't do something bad...should I just comment out all lines in config?
BrowserMatch "Mozilla/2" nokeepalive
#BrowserMatch "MSIE 4\.0b2;" nokeepalive Bdowngrade-1.0 force-response-1.0
BrowserMatch "RealPlayer 4\.0" force-response-1.0
BrowserMatch "Java/1\.0" force-response-1.0
BrowserMatch "JDK/1\.0" force-response-1.0
BrowserMatch ".*MSIE [1-5].*" nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0
BrowserMatch ".*MSIE [6-99].*" ssl-unclean-shutdown
I tried commenting out all lines in ssl.conf and httpd.conf and am still failing:
http://www.webpagetest.org/result/111206_54_2DT6D/
Find all posts by this user
Quote this message in a reply
12-07-2011, 06:49 AM
Post: #13
RE: Keep-Alive showing as not enabled but as far as i know it is
Yes, I would comment them all out. I can't imagine that you support browsers where it still matters (if there are even any users still on IE 4/5). That will clean up your config as well.

Did you restart the apache after commenting it out?

If so and you are still having problems then there has to be another one hiding somewhere. Is it possible that your apache instance is actually loading it's settings from somewhere else?
Visit this user's website Find all posts by this user
Quote this message in a reply
12-07-2011, 09:00 AM (This post was last modified: 12-07-2011 09:01 AM by gfm.)
Post: #14
RE: Keep-Alive showing as not enabled but as far as i know it is
According to OLM, there is not another instance of apache running on my server. Perhaps I can grep the entire server tonight for "downgrade"? Should I grep for other terms as well? Any ideas?

Oh...I did restart apache after, and did comment out everything.
Last--Do you think a server restart might do the trick?
Find all posts by this user
Quote this message in a reply
12-08-2011, 12:20 AM
Post: #15
RE: Keep-Alive showing as not enabled but as far as i know it is
A server restart shouldn't make a difference assuming the apache restart is actually working. I'd grep the whole machine for both strings just to be safe.
Visit this user's website Find all posts by this user
Quote this message in a reply
12-08-2011, 02:35 AM
Post: #16
RE: Keep-Alive showing as not enabled but as far as i know it is
I haven't greped the entire machine yet, but did discover new instances of this:
SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
in each site file in this directory:
/etc/httpd/conf/virtual/

I commented them out for each site file on the server, restarted Apache and then later the entire server, yet I am still failing...this is strange indeed. I will try greping the machine next.
Find all posts by this user
Quote this message in a reply
12-17-2011, 01:18 AM
Post: #17
RE: Keep-Alive showing as not enabled but as far as i know it is
With the help of an admin at my hosting company we finally figured this out...we found this Apache configuration file: httpd20_app.conf
and commented out this line:
#SetEnvIf User-Agent ".*MSIE.*" force-no-vary
and I now get an "A" on the keepalive test.

Now to solve my first byte issue...I can't get past a C. Any ideas?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)