Current time: 08-18-2018, 01:22 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
500 error and probs with index.php
11-04-2010, 02:04 AM (This post was last modified: 11-04-2010 02:07 AM by jacquelinek.)
Post: #1
500 error and probs with index.php
Can anyone tell me why i am sometimes getting 500 error on one of the links for my site? Specifically for http://www.wowbizspy.com/?mcsf_action=ma...&ver=3.0.1

Obviously it's not an actual page I've created. I recognize the number as being the latest version for wordpress.

Here are two webpage tests I've done:

http://www.webpagetest.org/result/101103...1/details/
http://www.webpagetest.org/result/101103...1/details/

Also the index.php has been giving me trouble off/on for a week or so. Thank you.

I am not sure where to start on this. The page loads fine.. although it's still not as fast as I would like. I just fixed a fast CGI error i was having all of a sudden (i heard it was due to my moving servers). I also recently fixed a problem with an image which had a forbidden error. Somehow it was chmoded to 644.

I am using a VPS on Dreamhost. I use wordpress, the w3 total cache plugin and Maxcdn. Thanks for any advice you have.




Actually i figured out that's a bad/misconfigured plugin. duh!

The only thing I dont understand is the index.php ...

Maybe fixing the plugin will help.
Find all posts by this user
Quote this message in a reply
11-04-2010, 03:02 AM
Post: #2
RE: 500 error and probs with index.php
What problem has index.php been giving you? FWIW, fastcgi will generate a 500 when it needs to re-spawn which is why I moved away from fastcgi and to mod_php (with x-cache) for my Dreamhost VPS that this site runs on.

That is, when Dreamhost isn't having network or other problems Sad

Thanks,

-Pat
Visit this user's website Find all posts by this user
Quote this message in a reply
11-04-2010, 04:49 AM (This post was last modified: 11-04-2010 04:50 AM by jacquelinek.)
Post: #3
RE: 500 error and probs with index.php
Hi and thanks for answering.. the index problem I was referring to was in the test. It was highlighted in red on the waterfall webpage tests from time to time and I wasn't sure why. I thought it was causing the 500 errors somehow. I just disabled a custom php.ini that I got from Dreamhost http://wiki.dreamhost.com/PHP.ini and it seems to have fixed the problem.

To begin with I had that php.ini in order to increase the memory for wordpress when posting/changing elements of the theme. I'm using thesis and apparently its a memory hog when it comes to making changes such as (changing columns etc).


Anyway, maybe I'll try your setup of mod-php/x-cache also. I'm not sure why i was under the impression fastcgi was any better maybe because it's listed as "recommended."
Find all posts by this user
Quote this message in a reply
11-07-2010, 04:16 AM (This post was last modified: 11-07-2010 04:24 AM by jacquelinek.)
Post: #4
RE: 500 error and probs with index.php
Can anyone else tell me why index.php is highlighted in red? The page test is calling it a time out.

Latest test is here.

http://www.webpagetest.org/result/101106_AVHG/

thank you.
Find all posts by this user
Quote this message in a reply
11-07-2010, 04:26 AM
Post: #5
RE: 500 error and probs with index.php
It's highlighted in red because it never responded (and it's what caused the test to timeout). I need to work on the UI a bit so it correctly shows that the request was sent and it reached the end of the 60 seconds with no response.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-07-2010, 06:52 PM
Post: #6
RE: 500 error and probs with index.php
Ok so i'm guessing then the time outs are still a problem of my website somehow.

Thank you for letting me know. I realize theres nothing wrong with the file, its something else network related.

Thanks again.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)