Current time: 09-20-2019, 03:21 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Strange results
11-02-2011, 08:33 PM
Post: #1
Strange results
Test performed with IE and private instance of WPT. Agent version 303.
Hi,

How to interpret these results? Is it an WPT issue or this situation is possible with IE7?

[Image: 1f6286944539e310.png]

[Image: ff81906ed105acb.png]

Regards,

Artur Sudnik
Find all posts by this user
Quote this message in a reply
11-02-2011, 11:33 PM
Post: #2
RE: Strange results
What is the strange part? The canceled requests or what looks like a bug in the connection view that drew the second request on the wrong connection (from the looks of it) or something else?

If it is the canceled requests then this would be a good place to start: http://blogs.msdn.com/b/ieinternals/arch...mance.aspx
Visit this user's website Find all posts by this user
Quote this message in a reply
11-02-2011, 11:34 PM
Post: #3
RE: Strange results
btw, if those screen shots are from a private instance, you must have grabbed the head from SVN because I just updated the waterfalls to have the mime colors in the connection view yesterday :-)

(it's fine, the trunk is stable and is usually what is running on the public server)

Thanks,

-Pat
Visit this user's website Find all posts by this user
Quote this message in a reply
11-02-2011, 11:36 PM (This post was last modified: 11-02-2011 11:37 PM by ash.)
Post: #4
RE: Strange results
(11-02-2011 11:33 PM)pmeenan Wrote:  What is the strange part? The canceled requests or what looks like a bug in the connection view that drew the second request on the wrong connection (from the looks of it) or something else?

If it is the canceled requests then this would be a good place to start: http://blogs.msdn.com/b/ieinternals/arch...mance.aspx

The strange part for me is connection view. Are there just two connections overlapping?

Thanks for the link.

Artur
(11-02-2011 11:34 PM)pmeenan Wrote:  btw, if those screen shots are from a private instance, you must have grabbed the head from SVN because I just updated the waterfalls to have the mime colors in the connection view yesterday :-)

(it's fine, the trunk is stable and is usually what is running on the public server)

Thanks,

-Pat

Yes, I work with trunk :-). I prefer new versions over any risks of new bugs.
Find all posts by this user
Quote this message in a reply
11-02-2011, 11:50 PM
Post: #5
RE: Strange results
The connection view looks to be a bug where a connection ID is being re-used (or something like that) - there should NEVER be 2 socket connect bars on the same connection :-(

Is the page publicly accessible? If so I'd like to try to reproduce the problem so I can get a fix in place (feel free to PM me or send a note to pmeenan@webpagetest.org). If the page isn't available, can you "Publish to http://www.webpagetest.org" the results and send me the link so I can see if it is just a drawing problem or if it was really an agent problem?

Thanks,

-Pat
Visit this user's website Find all posts by this user
Quote this message in a reply
11-02-2011, 11:58 PM
Post: #6
RE: Strange results
(11-02-2011 11:50 PM)pmeenan Wrote:  The connection view looks to be a bug where a connection ID is being re-used (or something like that) - there should NEVER be 2 socket connect bars on the same connection :-(
(11-02-2011 11:50 PM)pmeenan Wrote:  What is strange, from different location also running on IE7 I have correct chart.
Is the page publicly accessible? If so I'd like to try to reproduce the problem so I can get a fix in place (feel free to PM me or send a note to pmeenan@webpagetest.org). If the page isn't available, can you "Publish to http://www.webpagetest.org" the results and send me the link so I can see if it is just a drawing problem or if it was really an agent problem?

Thanks,

-Pat

Unfortunately this application is not publicly accessible and I am afraid I am not allowed to send any details about it.

Anyway - what does "Publish to http://www.webpagetest.org" mean? Is it possible to upload results to public instance?
Find all posts by this user
Quote this message in a reply
11-03-2011, 12:36 AM
Post: #7
RE: Strange results
Yes - in the settings.ini on the server you can include a publishTo=www.webpagetest.org which will add a link to each results page that gives a link for uploading the result to the public instance (for sharing): http://webpagetest.googlecode.com/svn/tr...ini.sample

It will upload the full result, including all of the data and screen shots so be careful doing it with sensitive data. It does upload it as a private (non-guessable, not logged) test so only people with the link should be able to see it but still best to be careful.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)