Current time: 10-17-2019, 11:29 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Startrender 1.16 s - but complete in 0.864 seconds
04-17-2011, 03:48 AM
Post: #1
Startrender 1.16 s - but complete in 0.864 seconds
???

http://www.webpagetest.org/result/110416...1/details/
Find all posts by this user
Quote this message in a reply
04-18-2011, 10:05 PM
Post: #2
RE: Startrender 1.16 s - but complete in 0.864 seconds
Yep, check out the screen shots (document complete is blank): http://www.webpagetest.org/result/110416...reen_shot/

The javascript in the head of your document (particularly the external reference) is causing it. If you move the javascript to the bottom of the page the rendering should happen earlier. The browser processes things in the order they are parsed and it can't process anything until it has loaded and executed the javascript blocks (including external code). When it reaches the end of the document there are no other external references left so it fires the onLoad event (document complete) but the render hasn't happened yet because those are done in a lazy fashion to be more efficient about painting to the screen.
Visit this user's website Find all posts by this user
Quote this message in a reply
04-21-2011, 07:22 AM
Post: #3
RE: Startrender 1.16 s - but complete in 0.864 seconds
Thank you - and here are the new results:

http://www.webpagetest.org/result/110420_XE_EY3E/

it works !
Find all posts by this user
Quote this message in a reply
04-21-2011, 08:52 AM
Post: #4
RE: Startrender 1.16 s - but complete in 0.864 seconds
Nicely done.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)