Current time: 10-18-2019, 02:32 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Really slow loading times > 20sec
11-05-2011, 03:54 AM
Post: #1
Really slow loading times > 20sec
Hi,

Not sure what's going on here but my loading times are terribly slow. Looking at the stats http://www.webpagetest.org/result/111104...1/details/, the biggest factors seem to be "Initial Connections" and "Time To First Byte".

The site is based around Prestashop's ecommerce with some tweaking and can be seen here http://www.sceneprestonoffice.com/

I've tried searching the forum for some answers but didn't have much luck. Can anyone shed any light?

A huge thanks in advance,

Philip.
Find all posts by this user
Quote this message in a reply
11-06-2011, 12:56 AM
Post: #2
RE: Really slow loading times > 20sec
1 - enable keep-alives (or fix whatever is preventing them from working). That will get rid of most of the orange bars and should help your times considerably.

2 - Enable gzip compression for your text resources (javascript, css, html). That's probably good for about a second in the test that you ran.

3 - The first byte time is going to be a function of your aplication itself. Since you are running on top of Presta Shop so you may have to ping them about tuning for performance (could be database or server configuration or it could be their code itself).

After that you should also test with IE8 or 9 which loads a lot more resources in parallel and will give you different things to focus on. It does look like you have a fair number of small graphics that are individual files that can be combined into image sprites which should help quite a bit as well.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-06-2011, 01:10 AM
Post: #3
RE: Really slow loading times > 20sec
Thanks Patrick.

I'll let you know how I get on.

Philip.
Find all posts by this user
Quote this message in a reply
11-06-2011, 02:57 AM (This post was last modified: 11-06-2011 03:01 AM by mediumd.)
Post: #4
RE: Really slow loading times > 20sec
Ok, so had a little look into enabling "keep-alive" and found that, with my configuration, it could only be done by my host provider. After quick email, these setting were activated and the difference is immense . . . http://www.webpagetest.org/result/111105_RR_239ZE/

It's even more apparent in my Chrome tests with times of around 30 seconds being reduced to just 7. Great stuff!

Can't wait to see what results your other suggestions will yield.

You've made my day, Patrick. Can't thank you enough.

Philip.
Find all posts by this user
Quote this message in a reply
11-07-2011, 11:14 AM
Post: #5
RE: Really slow loading times > 20sec
Glad to help. Let us know when you've made it through some of the other recommendations and we can weigh in with other areas you might want to look at.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)