Current time: 12-18-2017, 01:19 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Joomla site extremely slow
11-09-2011, 06:36 PM
Post: #1
Joomla site extremely slow
This is a new installation of Joomla 1.6 with the database from a previous 1.5 installation that was hacked, so it all had to be cleaned.

I wasn't involved with the new installation but am now taking over and the site is loading incredibly slowly 15-20 seconds
http://www.webpagetest.org/result/111109...1/details/

There seems to be a long delay at the start for the 'time to first byte', I'm not sure what is loading there, hope someone here can help me understand the info and fix the problem!!

During the new installation, the site was put on another domain and then moved - I'm wondering if instead of moving it, it was redirected and that is slowing it down?

Rob
Find all posts by this user
Quote this message in a reply
11-10-2011, 12:42 AM
Post: #2
RE: Joomla site extremely slow
The first byte time is kind of a black box from the outside so we can't provide a lot of direct visibility. I can say that it's not a redirect though. 90% of the time the first byte performance issues in joomla or wordpress are because of database queries (a lot of them and sometimes slow). The other 10% usually come from back-end requests to external services.

You can start by looking at your database slow query log to see if there are any common slow queries that can be helped by adding a database index. Beyond that it usually requires instrumenting the server code or experimentation with turning things on and off to see where the issue is.

If you have access to modify the php install then tools like New Relic or Dynatrace can be really helpful by telling you exactly where the slow code or queries are (I know New Relic has a free trial period, not sure about Dynatrace).
Visit this user's website Find all posts by this user
Quote this message in a reply
11-10-2011, 08:43 AM
Post: #3
RE: Joomla site extremely slow
Thanks very much pmeenan, so I can rule out some strange redirection process, that's good. I will start looking at the Joomla installation, as you suggest

Rob
Find all posts by this user
Quote this message in a reply
11-11-2011, 07:49 AM (This post was last modified: 11-11-2011 07:51 AM by Stingraynut.)
Post: #4
RE: Joomla site extremely slow
Re The delay before anything happens - I noticed today that I type in HTTP://sitename etc and nothing happens, then the URL changes to Http://www.sitename etc and immediately the page begins loading- I don't know why the page is showing the www ?

Rob
Find all posts by this user
Quote this message in a reply
11-11-2011, 07:53 AM
Post: #5
RE: Joomla site extremely slow
That is going to be completely unrelated. You must be using chrome with instant turned on or something like that where it predicts what you are typing and loads the page.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-11-2011, 08:23 AM
Post: #6
RE: Joomla site extremely slow
Thanks pmeenan - No I'm using FFox and typing into the address bar - there is a 10 second wait and the instant the address changes to http://www the site begins loading.

The .htaccess file has this as the last two entries

RewriteCond %{HTTP_HOST} ^.*$
RewriteRule ^/?$ "http\:\/\/www\.aussiebrewer\.com\.au\/" [R=301,L]
Find all posts by this user
Quote this message in a reply
11-11-2011, 09:00 AM
Post: #7
RE: Joomla site extremely slow
Ahh, gotcha. What does it look like when you test without the www on webpagetest? It could be that your web server is running out of clients to handle the connections and the 10 seconds is the time for a new client to free up (a common problem if you are using apache with mod_php and keep-alives enabled).
Visit this user's website Find all posts by this user
Quote this message in a reply
11-11-2011, 09:01 AM
Post: #8
RE: Joomla site extremely slow
It could also be that the browser doesn't update the address bar until the html starts coming in.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-12-2011, 12:03 PM
Post: #9
RE: Joomla site extremely slow
Hi again- I have performed the webpage test with and without the www

With WWW
[Image: withwww.jpg]

Without www[Image: nowww.jpg]

With www time to first byte went down to 6.8 seconds but the repeat test was slower

without WWW, which is the way I've been testing, showed 20.2 seconds!! but the repeat test was faster

Yes it could be the browser that is not updating the url until it receives the first byte. I don't know enough about this stuff to know what to do next.
Find all posts by this user
Quote this message in a reply
11-14-2011, 09:33 AM (This post was last modified: 11-14-2011 09:46 AM by Stingraynut.)
Post: #10
RE: Joomla site extremely slow
UPDATE:Not sure if this could be part of the problem - the website SHOULD be .com.au -in control panel the website is shown as .biz and under redirects it is being redirected to htttp://WWWdomainname.com.au

Seems to me this is a complicated way to arrive at the correct website?

Please can you give me any more advice? and if not, please could you give me any links where I can learn about this?

I didn't realise that serving up a web page had so many stages - I've never had a website load so slowly before and usually it's the image size and number that are the components that cause any delay.

I've never heard of 'keep alive' before, didn't know there was a "database slow query log" and never before encountered "the first byte performance issues in joomla or wordpress are because of database queries " although I usually work with Wordpress not Joomla

Thanks

Rob
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)