Current time: 05-27-2016, 08:22 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Private Instance doesn't show grades
06-22-2011, 12:29 AM
Post: #1
Private Instance doesn't show grades
I've just set up a private instance of WebPageTest so that we can performance test our pre-production website. First of all I need to say thank you for this tool! It is helping us find a lot of performance problems.

I've noticed that there are a couple of features missing from the private instance when compared to webpagetest.org. Could someone help me determine if I have a setup issue or if these features are not included in the 2.2 release of the private instance described here: https://sites.google.com/a/webpagetest.o...-instances
  • The top Nav bar is missing (the one with Home, Test Results...)
  • Grade Boxes are not displaying

Thanks in advance!
Find all posts by this user
Quote this message in a reply
06-22-2011, 12:33 AM
Post: #2
RE: Private Instance doesn't show grades
Ahh, I should be more careful with the CSS override sample :-) Go into your settings folder and rename custom.css back to custom.css.sample. I'll make the sample more innoculous for the next release (it is there so you can override the default UI without having to change the actual code and my default hides a bunch of stuff - doh)
Visit this user's website Find all posts by this user
Quote this message in a reply
06-22-2011, 12:41 AM
Post: #3
RE: Private Instance doesn't show grades
Ahh, that is classic. I probably should have looked at the config files a little closer.

Thanks for the quick response. Everything is up and running now!

Steve
Find all posts by this user
Quote this message in a reply
05-03-2016, 04:50 AM
Post: #4
RE: Private Instance doesn't show grades
In WPT v2.19 this seems to have disappeared: the file "custom.css.sample" is too small to have any impact on the grades.
Only stuff grades-related in the HTML seems so be "<div id="grades"></div>".
How to turn this option on, almost 5 years later? :-)
Find all posts by this user
Quote this message in a reply
05-19-2016, 09:54 PM
Post: #5
RE: Private Instance doesn't show grades
When I alter "$pageData['optimization_checked'] = 1;" from 0 to 1 in file "devtools.inc.php" I get a very basic view of the grades. See attachment.
What else needs to be altered in WPT to see these grades?


Attached File(s) Image(s)
   
Find all posts by this user
Quote this message in a reply
05-19-2016, 10:45 PM
Post: #6
RE: Private Instance doesn't show grades
What test agents are you using to run the tests? Only the desktop Windows agents run the optimization checks.
Visit this user's website Find all posts by this user
Quote this message in a reply
05-20-2016, 12:27 AM
Post: #7
RE: Private Instance doesn't show grades
(05-19-2016 10:45 PM)pmeenan Wrote:  What test agents are you using to run the tests? Only the desktop Windows agents run the optimization checks.

Thank you for the answer, Patrick!
That explains it. I use "From: Chrome Local - Xvfb - Chrome" <-- headless Chrome in virtual frame buffer.
Find all posts by this user
Quote this message in a reply
05-23-2016, 08:10 PM
Post: #8
RE: Private Instance doesn't show grades
Consider this part solved.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)