Current time: 08-21-2014, 12:21 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Script Issue...
06-29-2011, 08:52 PM
Post: #1
Script Issue...
Hi,

i am have a problem with the script below. It logs into my site fine and selects the search tab, but then i cant get it to enter data in to the search fields. it does however click the search button and i get an error back asking for search criteria.

a little background:
Our pages are made up of iframes and loaded in the DOM at the same time are the iframes for person search and other search pages. These all seem to have the same id's etc so is it getting confused on the id's for the text fields? if so how can i get it to pick the correct field?

thanks
niall

//log in
logData 0
navigate http://machine:9080/Curam
setValue name=j_username superuser
setValue name=j_password password
logData 1
submitForm id=loginform
waitforComplete

// select search person tab
clickandWait innerText=Cases and Outcomes


//Fill in Form

//setDOMElement id=Curam_Person_search1
setValue id=__o3id3

submitForm id=mainForm
clickandWait innerText=Search
Find all posts by this user
Quote this message in a reply
07-02-2011, 01:39 AM
Post: #2
RE: Script Issue...
If you have a bunch of frames with items that share id's it's going to be more difficult. Looking at your script, one thing that jumps out is that you aren't actually specifying a value for the search field. The id=__o3id3 is to identify the page element but there should be an actual value after that with what you want to populate the value with (see the setValue commands in the login part of your script).
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)