WebPagetest Forums

Full Version: Slow Site - First Byte See all I have tried
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Ok... my results are bad...I have been getting an "F" all day for First Byte.. it was ranging from 13 seconds to 19 seconds. Now I was going to post a result here but its giving me an "A or B" and I have not done anything.

This is a new site that I created in the past couple weeks. I am using Wordpress with an "Elegant Themes" theme. Elegant Themes has not been any help.. sad but true.

site: http://www.pictureperfectkeepsakes.com

I host with StartLogic (I am suspicious of their hosting is being slow). Also I have invested so much time into this theme I really do not want to just throw it away.

I have tried to fix the things I can.. but this is a theme and there are images used in the home page slider that do not have image sizes set (penalized for this) ... but I do not know how to do this because these images are entered into their epanel. All other images on the site have the attributes they need to accept these 5.

What I have tried to make it faster:

W3 Total Cache Installed (Tried others but this seems better)
CloudFlare Enabled (barely helped - if at all)
Optimized DB w/ PHPMyAdmin

Google took me off the first page.... could it because page is so slow?
FYI, I pulled one of your old tests from the test history with a long TTFB: http://www.webpagetest.org/result/120109_TE_2SMT5/

If you're up for trying it out, WP Engine has a 15-day free trial and their claim to fame is freakishly fast Wordpress hosting: http://wpengine.com/

Yes, the long first byte times are because of your hosting provider (just about all shared hosting providers don't do well with wordpress). W3 Total Cache can help reduce the impact of the hosting issues but a slow database will absolutely kill wordpress performance.
Time to first Byte is typically either application programming or hosting issues. I would not be surprised to find problems on a shared hosts.

In your report, you can see that the TTFB is slow for your application page but fast for your images. Typically this is a hardware limitation on the hosts. On shared systems, database and disk IO are often constrained.

You may want to try a dedicated WP provider or a VPS. Some VPS providers suffer from the same issues but at least you have the root access required to diagnose the issue.

I wrote a blog post: What is time to first byte? which helps provide some more background on this variable.

Some tests that I do are to measure the TTFB to these pages:

[ul]
Your application
Test page with simple call to database (open/close)
PHP info page
Static file
[/ul]

If you find latency in the first two then your database or application processing is likely the issue. If a PHP info page is slow, then the server may be bottleneck at a hardware level. If your static file is slow -- there are definitely underlying hardware/configuration issues. Just a general approach I use. Fixing this requires a lot more testing and effort but good quick run down to help know where to look.
Reference URL's