WebPagetest Forums

Full Version: First byte time >F< with W3TC, CDN, KeepAlive: enabled
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hello! I know this is pretty discussed. I read a lot discussions, but I just can't figure it out. I got everywhere A raiting except in First byte time which is F. It's around 3 seconds, sometimes more sometimes less. I use W3TC and free version of cloudflare and KeepAlive is enabled. I would be happy if someone could help me to figure out what's wrong with my Wordpress site.
And also why is mu page load time sometimes 3 seconds bus sometimes 8?
Do you have a link to a test result (maybe several with the varying load times)?
Ok. Here are some results, but I temporary disabled CDN so I get some B.
But I don't think that Cloudflare affects my TTFB it's the same.

http://www.webpagetest.org/result/120216_ZD_38NTR/
http://www.webpagetest.org/result/120216_Y6_38NY4/
http://www.webpagetest.org/result/120216_ZG_38PMZ/

I wanted to look at W3TC debug info, but I don't know why it won't show any info when I enable it. I tried to find why it won't work but couldn't find answer and I posted tread at wordpress.org but none replied.

And here's with enabled CDN. TTFB is more that 3s. Could it be that high because my hosting server is in Latvia?
http://www.webpagetest.org/result/120216_ZA_38TNM/
No, the long time isn't because of the location - At most you're talking about 200ms or so to get to Latvia.

I don't see any comments in the HTML of your page at all - http://www.webpagetest.org/response_body...&request=1 (should be at the end if W3TC was working).

Sorry, I don't know why W3TC doesn't seem to be working at all but it would be worth it to try Supercache - lots of people have had luck with it when they couldn't get W3TC working.
Thanks for helping Patrick.
I deactivated W3TC and Activated Supercache.
Here are results:
http://www.webpagetest.org/result/120216_B3_38W3B/
I think there's some kind of error, because there isn't screenshot of my page. I tried couple times.
TTFB is better, but now I get F in Cache static content. So if I got with W3TC A in Cache static content, doesn't that mean the W3TC was working? By the way I didn't see anything about supercache in page source, so that mean Supercache isn't working?
Could you turn off that minification application?
Did you mean disable Supercache? Ok I disabled both Supercache and WP-minify.
http://www.webpagetest.org/result/120216_TF_38WP5/
Is alright that in screenshot isn't my page but some other image? And time to first byte is much better. Now my site seems much faster.
But now I got F in Cache static content. So is there something I could do to improve since I don't use W3TC which took care of it?
That looks like the Cloudflare protection page (which means it didn't test your site at all). Cloudflare usually allows WPT through but you should go in and turn down the security settings for now while you do the testing.
Did that. Now I could complete test. Here are results:
http://www.webpagetest.org/result/120217_23_38X30/
http://www.webpagetest.org/result/120217_0M_38X41/
http://www.webpagetest.org/result/120217_9D_38X52/

Still bad at First byte and Cache static content, any way to fix that?
Since W3TC doesn't seem to be kicking in you should try something like Super Cache. To get to the actual root cause you can install the debug queries plugin : http://wordpress.org/extend/plugins/debug-queries/ which will show you information about the database queries (which s probably why it is slow).
Pages: 1 2
Reference URL's