MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Struggling with gzip on js and css

WebPagetest Forums

Full Version: Struggling with gzip on js and css
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi
Test results are here - http://www.webpagetest.org/result/120220_6Y_39W9F/

According to this it tells me that the js and css are not gzipped, yet the html is. I have modded vhost.conf (Plesk control panel so cant touch httpd.include) to include the relevant document types and pointed it to the root web folder (httpdocs).
Am I missing something?

Regards

Doc
Two possibilities come to mind:

1 - You have a rule in place somewhere (.htaccess or config) that is disabling gzip for IE.

2 - mod_deflate isn't installed and html compression is actually being done by the application itself.
Hi Patrick
Those are the ones I'd checked as well:-
I have all the AddOutputFilterByType types in place in the htaccess for the catalog folder.
mod_deflate is an installed module.
Confused is an understatement at the moment!
Thanks

Doc
Ok, bit of an update on this. Just checked the webpage elements on http://www.gidnetwork.com/tools/gzip-test.php and the css and js are both showing as gzipped from the server.
Confused! Any ideas?
Thanks

Doc
You must have an IE specific rule active somewhere. Using WPT you can see, that Firefox, Chrome and IE9 all get gzipped responses. IE 7 and IE 8 do NOT.
Hi LepienM

I'd only tested against IE7 and 8 which are the UK links hence why I hadn't spotted that. That has helped to track it down.

I had an old version of instructions in htaccess, I had bMSIEs6 instead of bMSI[E] as the exclusions

Thanks
Doc
Reference URL's