MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - 99997 ???

WebPagetest Forums

Full Version: 99997 ???
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Pat,

on private instance, version 2.5 I get the following error:
A scripted test returns result code 99997 even though on the agent in IE everything looks fine:
logData    0
logData    1
setValue    class=text    hamburg
clickAndWait    name=btnSearch
For information (don't know whether that's relevant for the error):
The hole visible content of the site is in an iFrame, so using javascript directly fails:
logData    0
logData    1
execAndWait    getElementsByClassName('text')[0].value='Test';
execAndWait    getElementsByName('btnSearch')[0].click;

Error reproduced on public agents:

Same test without logData works (but we need to measure single step):

Thanks for help,
regards Nils
I opened up a bug so I don't lose track of it:

I tried it as a combined 2-step script and it still timed out:

I think the one without logdata only worked because the first step completed ok but the second step still caused a timeout on my side somewhere.
something new about this?
Hi Pat

I am working with Andy Davies on a private WPT project.

I am also getting occasional "result (error code) 99997" on tests targeted at Google Chrome. All other browser types are ok. Issue first occurred on July 10th but was fixed by an agent restart, but problem has just re-occurred and rebooting has not fixed it this time.

URL being tested but seems to do it for any of the url's (any domain) I am testing.

The waterfall appears to complete in the expected time, but the test itself is always recording a timeout.

This is in a private instance. I'm not quite sure of the version (is there a file that shows the version somewhere?) but its from around end April / early May this year.

The chrome agent is Version 28.0.1500.72 m

I have repeated against Dulles and it was OK.

Any ideas/suggestions?


Hi Pat,

I'm seeing a similar issue on SpeedCurve, the run last night generated hundreds of tests where the waterfall looks fine but the page still times out.

have hundreds more of these if you need to debug them. Agree that they all appear to be chrome related.

I'll try upgrading to the latest agent for tonights run.
Try updating the test agent. I know that I made changes in the last moth or so to deal with timeouts because of invisible browser activity that was dragging things out:
Yep that fixed things for me. It looks like agents get updated quite regularly. Is there anyway for test agents to pull updates directly from the main webpagetest instance so they're always using the latest version?
Not currently. I've considered building in support for an update check directly in the server but I was a bit worried about the software automatically doing updates without someone being in control over it. Say it updated right in the middle of the night and broke your testing for example.
Same issue here at Fasterize and updating the test agent fixed the issue.
Thanks !
Thanks Pat.

Update of the agent also appears to have worked for me too.
Reference URL's