MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Browser not getting past blank page

WebPagetest Forums

Full Version: Browser not getting past blank page
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hello, for some reason on one machine that I have the wptdriver setup on whenever I attempt to run a test on it, it opens the browser (firefox or chrome), navigating to the blank page and then it just sits there. No attempt is made to load the site. Eventually it times out and attempts to do the next site but again sits at the blank page.

I have installed this driver on other machines and it has run without a problem. Does anyone have any idea why this would be happening?
Are you running the 2.7 version of WebPagetest? There were changes needed in the extensions to support changes in Chrome and Firefox so if you are running an older version it could explain what you are seeing.
Currently running version 2.7.2, the extensions are the newest ones I believe. I tried setting up the drivers on another machine as well by copying the exact same folder from the non-working machine to the new one and it worked perfectly. It is only this individual machine it seems, I wish I could provide more information but I have been unable to reproduce the bug on any other system.
Any antivirus on the machine that may be interfering? Just a shot in the dark.
Disabled the antivirus and still ran into the issue, turns out the user was not actually running it as administrator, only using an account that had admin access and was claiming it to be run as administrator.

However with the most recent update to Firefox on Windows 7 the same blank page only issue is appearing once again. Using the same version of Firefox on an XP machine with the same driver is working, however the Windows 7 machine is having issues. Chrome on Windows 7 is not running into the blank page issue though. Are there additional changes to the extensions that have been released within the last month?
I updated the agents recently to deal with a Chrome change in Chrome 23 (Canary) but the Firefox plugin side of things hasn't changed in quite a long time. You can try updating to the latest to see if it helps -
I just updated to the latest version of the extensions and I am still running into issues. Is it possible that the newest version of Firefox is blocking the extension from loading? Is there something like with chrome where you need to set a flag to allow that extension to be used?
No, I'm running Firefox 15 and Chrome 21 and 23 on the public instance and not seeing any issues with the extensions loading. What version of Firefox are you seeing issues with?
I am seeing it with the latest version of Firefox 15. Is there any way for me to produce debug logs that might give a little more insight into why this is happening on this machine and not others?
Best bet is probably for me to provide a debug build and instructions on how to capture the output. Things are kind of swamped right now but I'll see if I can include it with a new 2.8 release in the next couple of days.
Pages: 1 2
Reference URL's