WebPagetest Forums

Full Version: 15 seconds to load a page. Please help out
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

Based on test results my website have 3341ms Time to First Byte. its taking 15 seconds for page to load with 1.7 megs of info.

http://www.webpagetest.org/result/120910...2712284b0/

Does anyone have any idea or advice how to resolve this issue.

I am using dreamhost and my website was made with wordpress.

Please help

Thanks you
Start by installing the W3 Total Cache plugin. It will let you cache the HTML which will help with the first byte times and it will also give you the ability to combine some of those css and js files.

You need to take a look at your .htaccess config and make sure that gzip is enabled for text types (particularly the html, css and js). http://www.webpagetest.org/result/120910...press_text That alone will save 450KB.

Those changes should cut your times in half or so. Beyond that there is quite a bit you can do to get the site to load faster but it will require actual dev work (delay loading the hidden panels in the slide show for example).
Hi thank you for your response.

I do have W3 Total Cache plugin installed, however its not actually doing what its suppose to do correctly i believe?

I posted a thread up on another forum and one of the moderator said "I see you have the cache installed but its not doing a single thing that it claims to do"

Here is the link as reference from my conversation with the moderator.

I also sent an email to my hosting company but have yet to receive anything.

Any suggestions on how to fix W3 Cache plugin?

http://www.kriesi.at/support/topic/footerphp
Some of the W3TC settings actually require manual configuration so I'm not surprised that they aren't active.

To enable browser-side caching of your images, css and js you need to go to the "Browser Cache" and turn on the expires header (css & js as well as media). If you turn on cache control, make sure to change the setting to cache("public") as the default will disable browser caching.

I'm not sure why the page cache isn't performing better. Try switching from enhanced to basic to see if that works any better. It could also be that something is preventing the page cache from being used. On the "general" settings page for W3TC there is a debug setting. Turn on the debug info for the page cache and hopefully it will provide some information.

For gzip, add this to your .htaccess file:

Code:
<IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/plain    
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE text/xml    
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE text/javascript
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    AddOutputFilterByType DEFLATE application/json
</IfModule>
Hi pmeenan,

thank you for your advice as i am now able to change my speed from 60 out of 100 to 82 out of 100. However, the WT3 cache plugin is still now working properly and not exactly too sure why. But i do have an idea and was wanted to ask for your opinion.

Few weeks ago i changed my website from http://www.possmma.us to http://www.poss.asia and transfer all the files over under the same hosting company. unfortunately, i think i am still missing a few steps to finalizing everything because certain pages on the website still displays the old url.

Could this be the reason why Wt3 is not working properly?

Also, i understand this is off topic, but was wondering if you knew what are the next steps i would need in order to make sure all pages have url poss.asia. i tried to update the changes in in the wp-config.php for mysqldatabase, however every time i make the adjustments it, when i log in it asking me to create new username and password for word press.

Any help would be appreciated.

Thank you
I don't think that would be related to the W3TC issues but my guess is the old and new sites are referencing the same database (or a copy of the old database) and something in there is still configured with the old URLs. Do you have redirects in place to redirect all of the old content to the new domain?

Did you dump the database from the old site and load it into the new database or are you trying to point to a new database (that won't be pretty)?
Reference URL's