WebPagetest Forums

Full Version: Test History start new test
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
When I try and retrieve any test results from the test history which have been created using the API and the following script.

http://www.webpagetest.org/runtest.php?k...1\&noopt=1

All I get when clicking on the search results is "Sorry, this test was cancelled before it ran!"

for example

http://www.webpagetest.org/result/120912_8C_CSS/

What am i doing wrong?
Does your code call ANY API entry points after submitting the test? The cancelled message should only ever appear if the test was successfully submitted but then the cancelTest.php API was called (or the test was cancelled in the UI).
(09-13-2012 09:31 PM)srenshaw Wrote: [ -> ]When I try and retrieve any test results from the test history which have been created using the API and the following script.

http://www.webpagetest.org/runtest.php?k...1\&noopt=1

All I get when clicking on the search results is "Sorry, this test was cancelled before it ran!"

for example

http://www.webpagetest.org/result/120912_8C_CSS/

What am i doing wrong?

I think I can answer my own question, seems there's not a London IE9 test location and that's what i've set my script to use.
Nope that doesnt appear to be the cause I still get an error with IE7 & IE8
Can you send me an email with the exact runtest.php URL you are requesting (including the test URL and API key)? You should be able to manually plug it into a browser and see if your script is performing the same way as the browser.

Do you have a bot or something that may be scraping the progress HTML and accidentally pushing the cancel button?

For 120912_8C_CSS I see a call being made to cancelTest.php shortly after a load of the result page from what looks like a private showslow instance (like 9 seconds after getting to the progress page).

The button is in a form so a normal bot shouldn't trigger it.
Reference URL's