MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - IE keep-alive = F | Firfox keep-alive = A

WebPagetest Forums

Full Version: IE keep-alive = F | Firfox keep-alive = A
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

When I run a test on our sites home page, results for Keep Alive Enabled vary from A to F based on browser selected.

Firefox always returns A 100/100

IE 8 or 9 always returns F 0/100

Also, on the Firefox tests, the first request always goes to ocsp.verisign.com, while first request for IE always goes to our site URL with no request of verisign ever.

Does anyone know why this might occur?

Thank you.
For the keep-alive issue, you have a browsermatch rule in your Apache config that is disabling keep-alive's for IE only. It used to be part of the default Apache configs. Check the end of this blog post - http://blogs.msdn.com/b/ieinternals/arch...-slow.aspx

Basically, find the browsermatch rule and delete it. There's no good reason for it to be there.

On Firefox, it is checking for certificate revocation for your SSL cert. IE doesn't bother checking.
Patrick,

Thank you for the reply and the blog post. After posting last night I started loking at our conf files and found the following:

In SSL.conf:
SetEnvIf User-Agent ".*MSIE.*" \ nokeepalive ssl-unclean-shutdown \ downgrade-1.0 force-response-1.0

In HHTPD.conf:
BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0
force-response-1.0

In this case it looks like the issue is in the SSL.conf settings.

Is it recommend to have a nokeepalive for IE 1-5 or 1-6? Or just delete altogether?
Just delete both altogether.

The problems were with a beta version of IE5 and some earlier versions that there's no chance people are actually still using.
Thank you for your reply.
Reference URL's