MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - TTFB on later images

WebPagetest Forums

Full Version: TTFB on later images
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I've checked the forums and I didn't see anything that addressed an issue I'm having and I'm hoping someone can provide some suggestion as to what may be going wrong.

My site is getting slow TTFBs. I know I have an issue with the initial response, where I'm looking for is an explanation of how/why this would happen with seemingly random files in the middle or even end of the page.

Test Results:

http://www.webpagetest.org/result/120927...1/details/

The content download is fast once started, but there are a lot of images with long (e.g 1.7 second) TTFB.

Anyone have any experience with this, know what could cause it, or what could help it?

Thanks for your time.
What does your stack look like?

Is IIS generating the responses directly or is it sending requests somewhere else or pulling from the network?

Is there any request filtering/bot protection that may be doing IP lookups?

Does it have the equivalent of an access log where it logs the time a request takes from it's perspective?
Thank you! I will look into these things. I appreciate the time and effort you put into this site and that you addressed my question.

Jim
We resolved the issue with our slow TTFB items in the middle of the page through a combination of things.

Caching some content on the server to reduce database lookups
Updated MS AjaxControlToolKit
Started pulling some items from available CDN sources

We still have room for improvement, but those changes alone made a huge improvement.

Thanks Again
Reference URL's