WebPagetest Forums

Full Version: Cache static content: F
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
I have all other "A" but only Cache static content is "F".

In my wordpress site at http://www.echeion.it I have W3 Total Cache installed and I'm also using google page speed service. In the details of your test I see:

FAILED - (No max-age or expires) - http://googleads.g.doubleclick.net/pagea...echeion.it
FAILED - (No max-age or expires) - http://googleads.g.doubleclick.net/pagea...echeion.it
FAILED - (No max-age or expires) - http://srv.juiceadv.com/banner_iframe.as...35&tipo=22
FAILED - (No max-age or expires) - http://www.google.com/pagead/drt/ui
FAILED - (No max-age or expires) - http://fonts.googleapis.com/css?family=Patua+One
FAILED - (No max-age or expires) - http://img4.juiceadv.com/Clienti/Illy/00...l=12213589
FAILED - (No max-age or expires) - http://www.google.com/pagead/drt/ui
FAILED - (No max-age or expires) - http://googleads.g.doubleclick.net/pagea...echeion.it
FAILED - (No max-age or expires) - http://tracking.optin-machine.com/?b_id=...0067e7&a=d
FAILED - (No max-age or expires) - https://googleads.g.doubleclick.net/page...7huJeLt3Yr
FAILED - (No max-age or expires) - http://srv.juiceadv.com/banner_iframe.as...35&tipo=22
FAILED - (No max-age or expires) - https://apis.google.com/js/plusone.js
FAILED - (No max-age or expires) - http://1-ps.googleusercontent.com/h/www....91z4L.webp
FAILED - (No max-age or expires) - https://googleads.g.doubleclick.net/page...7huJeLt3Yr
FAILED - (No max-age or expires) - http://www.google.com/pagead/drt/ui
FAILED - (No max-age or expires) - https://googleads.g.doubleclick.net/page...7huJeLt3Yr
FAILED - (5.0 minutes) - http://1-ps.googleusercontent.com/h/www....LFZtK.webp
FAILED - (5.0 minutes) - http://1-ps.googleusercontent.com/h/www....5xKrm.webp
FAILED - (5.0 minutes) - http://1-ps.googleusercontent.com/h/www....91z4L.webp
FAILED - (5.0 minutes) - http://1-ps.googleusercontent.com/h/www....xml1Z.webp
FAILED - (5.0 minutes) - http://1-ps.googleusercontent.com/h/www....ESZ-V.webp
FAILED - (5.0 minutes) - http://1-ps.googleusercontent.com/h/www....f_Wu7.webp
FAILED - (5.0 minutes) - http://1-ps.googleusercontent.com/h/www....yXCE1.webp
FAILED - (5.0 minutes) - http://1-ps.googleusercontent.com/h/www....m98qW.webp
FAILED - (5.0 minutes) - http://1-ps.googleusercontent.com/h/www....1wh6c.webp
FAILED - (5.0 minutes) - http://1-ps.googleusercontent.com/h/www....KEwT5.webp
FAILED - (5.0 minutes) - http://1-ps.googleusercontent.com/h/www....qNOap.webp
FAILED - (5.0 minutes) - http://1-ps.googleusercontent.com/h/www....BLXns.webp
FAILED - (5.0 minutes) - http://1-ps.googleusercontent.com/h/www....2fVxN.webp
FAILED - (5.3 minutes) - http://connect.facebook.net/it_IT/all.js
FAILED - (10.6 minutes) - http://googleads.g.doubleclick.net/pagea...=r20120211
FAILED - (30.0 minutes) - http://platform.twitter.com/widgets/follow_button.html
WARNING - (60.0 minutes) - http://pagead2.googlesyndication.com/pagead/osd.js
WARNING - (60.0 minutes) - http://pagead2.googlesyndication.com/pagead/show_ads.js
WARNING - (12.0 hours) - http://www.google-analytics.com/ga.js
WARNING - (24.0 hours) - http://pagead2.googlesyndication.com/pag...ces/it.png
WARNING - (24.0 hours) - http://pagead2.googlesyndication.com/pag...s/icon.png
WARNING - (24.0 hours) - http://pagead2.googlesyndication.com/pag...n_embed.js
WARNING - (24.0 hours) - http://pagead2.googlesyndication.com/pag...ts/ryo.swf
WARNING - (24.0 hours) - http://pagead2.googlesyndication.com/pag...tainer.swf
WARNING - (24.0 hours) - http://pagead2.googlesyndication.com/pag...000000.png
WARNING - (24.0 hours) - http://pagead2.googlesyndication.com/pag..._black.png
WARNING - (24.0 hours) - http://pagead2.googlesyndication.com/pag...00_250.swf
WARNING - (24.0 hours) - http://pagead2.googlesyndication.com/pag...IN_ALT.swf
WARNING - (24.0 hours) - http://pagead2.googlesyndication.com/pag...00_250.xml
WARNING - (6.6 days) - http://www.echeion.it/wp-content/uploads...249817.jpg

Do you think I can do anything to improve the results? My website looks like is loading 3 secs or more before start to displaying content, might it be related?
The issues won't be related to the delay in the first view, the requests get loaded anyway but it will make later repeat views slower. It looks like you are running the content through Page Speed Service as well which is adding a layer of obfuscation to your actual headers (I think they may have a default of 5 minutes if the origin doesn't specify an expires).

In W3C there is a tab in the settings for using the browser cache. You need to change the setting to something like cache-control: public (with an expires time). I believe the default setting makes the static resources not cacheable.
Thank you very much!

I removed the google page speed service, I was not sure if the website was loading better or not.

I tried to run the test again and the result is much worse, please take a look http://www.webpagescreenshot.info/img/39...01362333PM

In my browser cache settings "Cache control headers" is not checked. http://www.webpagescreenshot.info/img/99...01362749PM

Do you think I can improve the loading time and speed test result if I just enable the cache control headers? Is there any other advices?
Looks like the cache headers your YOUR actual content is fine but there is a bunch of 3rd-party content that is not (juiceadv.com in particular).
Most of the No-Max Age requests are for ads which by nature aren't cached and shouldn't be. You're never really going to have a perfect cache static score if you have ads on your site.
(02-07-2013 11:16 AM)Chris Stark Wrote: [ -> ]You're never really going to have a perfect cache static score if you have ads on your site.

That would depend on the type of "ads". If your using, say, static banners and feeding them from your own domain or a CDN then it shouldn't be an issue. Where this seems to become an issue, is accessing content dynamic, fonts etc from another url.

While my Cache content is not an F, it's a C and the urls causing the issue are:

FAILED - (163.6 KB, compressed = 110.8 KB - savings of 52.9 KB) - themes.googleusercontent.com/static/fonts/ubuntu/v4/nsLtvfQoT-rVwGTHHnkeJj8E0i7KZn-EPnyo3HZu7kw.woff
FAILED - (157.4 KB, compressed = 111.0 KB - savings of 46.3 KB) - themes.googleusercontent.com/static/fonts/ubuntu/v4/hHs22WBTTzMhSqc5uBBDKg.woff

I've given up trying to fix it.
Reference URL's