WebPagetest Forums

Full Version: Google PSS isn't deferring js
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Even with the option enabled..

What can I do to aid it in deferring the js? I'd like to max the score I've got now which is 98 Cool

http://www.webpagetest.org/pagespeed.php...1&cached=0
Google PSS looks interesting. I'm going to try stacking it with Cloudflare to see if doubling up is of any benefit, at least while it's still free.
Actually cloudflare doesn't work at all with Google PSS. I've tried that.
You should ping the team on their discussion group - could be something with the headers on the js or something like that: https://groups.google.com/forum/?fromgro...ce-discuss

Chaining cloudflare and PSS might be possible if you put cloudflare first but adding 2 proxies in front of your content is probably not a great idea.
I've actual setup a number of sites chaining Cloudflare and PSS after reading this and it works fine. You can see both of them in my page source code. You have to setup the following

A Record > website.com > xxx.xxx.xxx.xxx > Cloudflare Off
A Record > origin.website.com > xxx.xxx.xxx.xxx > Cloudflare On
Cname Record > http://www.website.com > pagespeed.googlehosted.com > Cloudflare On

You also have to add the origin. subdomain at the host. It's pretty impressive stacked together. You can see http://www.digitalmgmt.com example here http://www.webpagetest.org/result/130206_04_CEM/

Under a second on first load and there still more I could do with optimizing PSS. PSS will say that it's not setup in the UI but it's functioning.
Unfortunately when I try to enable cloudflare & PSS it gives me this:

DNS Points to Prohibited IP
You've requested a page on a website (https://www.vgchat.us) that is on the CloudFlare network. Unfortunately, it is resolving to an IP address that is creating a conflict within CloudFlare's system. If you are the owner of this website, you should login to CloudFlare and change the DNS A records for https://www.vgchat.us to resolve to a different IP address.

Timestamp: Sun, 10 Feb 2013 18:18:31 -0800

Your IP address: ----

Requested URL: https://www.vgchat.us/forum/forum.php

Error reference number: 1000

Server ID: FL_22F12

Process ID: PID_3ee0aaa972c045b

User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.57 Safari/537.17
(02-11-2013 12:21 PM)avalanch Wrote: [ -> ]Unfortunately when I try to enable cloudflare & PSS it gives me this:

DNS Points to Prohibited IP
You've requested a page on a website (http://www.video-game-chat.com) that is on the CloudFlare network. Unfortunately, it is resolving to an IP address that is creating a conflict within CloudFlare's system. If you are the owner of this website, you should login to CloudFlare and change the DNS A records for http://www.video-game-chat.com to resolve to a different IP address.

Timestamp: Sun, 10 Feb 2013 18:18:31 -0800

Your IP address: ----

Requested URL: http://www.video-game-chat.com/forum/forum.php

Error reference number: 1000

Server ID: FL_22F12

Process ID: PID_3ee0aaa972c045b

User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.57 Safari/537.17


Hi,

Try changing the www record to a gray cloud in your DNS settings that is pointing to Google Pagespeed (you currently have it orange). Curious if that fixes it.


As Patrick mentioned, however, you may not want to stack multiple proxies in front of your site.
Yeah, I think I'll just pass on doing that... the downtime isn't very good for the crawlers & people trying to visit my site. For now though google PSS by itself is doing very good.
Reference URL's