MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Black screenshot and black video.

WebPagetest Forums

Full Version: Black screenshot and black video.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a strange issue that it's related to tha fact that I must connect to the RDP to make dummynet run.

This cause black screenshot and black videos.

How to make dummynet start without logging in to the RDP. I put it in the startup folder but until I login to the RDP the prompt of dummynet is blocked to the first 2 line.
Black screen shots will happen if the test machine's desktop is locked. You need to make sure to disable any screen savers and any power management settings that turn off the display.

You should not have to connect to the machine to get it to run. Did you configure the machine to automatically log in? step #1 in the install instructions:

If you RDP to a machine you need to reboot it when you are done. If you disconnect then it will lock the desktop (note at the end of the machine configuring instructions).
But the ipfw.cmd must be in the Startup folder or not?

I run the command - "control userpasswords2" but a window appear and I don't see any option to automatically login.

When I open the RDP the user is already logged in.

Probably I found the option, but is this secure?

In the test then the machine show the Username and Ip address and so anyone can login.

Is there a way to hide ip and name or change them?
If you run "control userpasswords2" you uncheck the "require a password" box and it will automatically log in as the given user when the machine starts up (and run anything in the startup folder).

Where in the tests are the user name displayed? The password is also not displayed. The only problem is if somebody has physical access to the machine in which case yes, it is a problem (though if you run the test agent inside of a VM then physical access to the console does not give them access to the desktop).
In the "tester: ....."

So the required login is only for local? Great.
Everything now is working fine.
I hope there is a way to change the showing name and IP.
If not I will change it from PHP code.
tester: should be the computer name, not the user name. You can hide it but it really helps if you have multiple test machines for a location and you start getting bad or unexplained results.
Ok thanks for your support.

Maybe I will only suppress the ip address via PHP code.

When I will launch it I'll tell you.
If you execute a test while RDPing the agent, if the RDP session is minimized it will also create black images. If you are watching the RDP, it will capture correct screenshots.
Reference URL's