WebPagetest Forums

Full Version: Waterfall Problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

I've so happy for this community because of this excellent tool and people Smile Firstly thanks for all!

Ehmm, Also now I need ask a question for my problem. As you can see that waterfall view on the report, all resources waiting to bgr_head.jpg. I can't figure out that problem. I don't understand why this happen and I tried to some combinations, for example I moved this file to static subdomain and later moved to root, try to change jquery location but I didnt handle this. Is there any idea for fixing that? Because I'm going crazy now Undecided

Thank you

http://www.webpagetest.org/result/130416...1/details/
I captured a dev tools timeline (under Chrome in advanced settings) to see what was going on and the browser is locked up in "Evaluate Script" for http://static2.mynak.com/js/core.js?id=25

Unfortunatly there's not a lot of detail on what it's doing becuase there's just a massive gap after a forced layout and the js is minified and collapsed down to just a few lines.

It has nothing to do with the domains or how the files are served. The problem is something expensive that is happening in your javascript itself.

If you have a dev version of the site I recommend debugging it with Chrome's dev tools, possibly adding console logging, etc (or just disabling chunks of the code) to figure out what it is doing.
Reference URL's