MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - wpt stops measuring before page is fully loaded

WebPagetest Forums

Full Version: wpt stops measuring before page is fully loaded
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I got a case related to google map where stores can be displayed as pins on a google map page.

I've run a few of test either on public or private instance. The wpt for most of time stops measuring before the pins are loaded without any timeout error. I can't figure out why the result is flicking. If the pins can't be loaded due to some reason, I think there should be at least some error in result.

http://www.webpagetest.org/result/130708_3M_B7J/
http://www.webpagetest.org/result/130708_AN_B92/ (first view of this run loaded the pins however)
WebPagetest will generally wait for 2 seconds of no network activity after the onload event before it considers a page done. It looks like the pins may load after the load event and are loaded by ajax so if there is a delay before that happens then the test will end before they get loaded. You can force it to wait by setting a DOM Element for it lo look for in the advanced settings (assuming the pins have a unique DOM element). In that case the test will keep running until the specified element shows up on the DOM (if there is a specific network request you can also tell it to wait for a network request instead of a DOM element).
Thank you very much for your reply Patrick.

Once the pins are loaded, there will be an item whose id is "store_0". I have placed that item "id=store_0" into advanced setting tab, but when running the test, it still doesn't wait for that element to appear before finishing the test. http://www.webpagetest.org/result/130710_R8_3QY/
It's a bug of AUT that the pins will not appear in Firefox when you visit it first time, but the site under test is okay for this in IE8. http://www.webpagetest.org/result/130710_J9_3KN/ I expect my test can capture such issue.

Furthermore, I need to do another test involving several steps on this page for which I have to write script. I write it as below, but it doesn't look like working correctly. I'm not sure how I can force the measurement to the result page of statement "execAndWait document.querySelector("button.icon").click();" continuously measuring until the dom "id=store_0" appears.

logData 0
setEventName findStore
navigate http://global.ecco.com/en/service/find-a-store
setDOMElement id=storeSearch
setValue id=storeSearch Shanghai
logData 1
combineSteps
setEventName search
execAndWait document.querySelector("button.icon").click();
execAndWait $('#store_0').ready(function(){return;});
is this wait period configurable?

basically, i am seeing a case - where page is not fully loaded (as i know how fully page load would look like) - but WPT seems to be finishing it early on.

(07-08-2013 10:34 PM)pmeenan Wrote: [ -> ]WebPagetest will generally wait for 2 seconds of no network activity after the onload event before it considers a page done. It looks like the pins may load after the load event and are loaded by ajax so if there is a delay before that happens then the test will end before they get loaded. You can force it to wait by setting a DOM Element for it lo look for in the advanced settings (assuming the pins have a unique DOM element). In that case the test will keep running until the specified element shows up on the DOM (if there is a specific network request you can also tell it to wait for a network request instead of a DOM element).
Reference URL's