MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Images not recognised for "Compress Images"

WebPagetest Forums

Full Version: Images not recognised for "Compress Images"
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

we just switched our hosting service provider a few days ago and I was now testing our site again. I noticed that most often (but not always), the "Compress Images" score is missing (i.e. "N/A"), though the page does have a number of images and they are delivered by the Apache webserver with the correct content-type: image/*

You can see an example here: http://www.webpagetest.org/result/130909_RS_6FE/

What could be the reason for this behaviour - and is this a problem only for the score in webpagetest.org or would that somehow affect real-world users?

Thanks for any ideas, suggestions.
WebPagetest only looks at JPEGs right now (for lossy optimization) and doesn't do anything for png's or gif's which is why you are seeing it not detect your static images.
(09-10-2013 01:08 AM)pmeenan Wrote: [ -> ]WebPagetest only looks at JPEGs right now (for lossy optimization) and doesn't do anything for png's or gif's which is why you are seeing it not detect your static images.
That makes sense!

If this behaviour stays for longer, maybe the Glossary for Compress Images could be updated. It currently reads:

Code:
What is checked     
GIF - All pass
PNG - Must be 8 bit or lower (no 24-bit PNGs will pass)
JPEG - Within 10% of a photoshop quality 50 will pass, up to 50% larger will warn and anything larger than that will fail.
The overall score is the percentage of image bytes that can be saved by re-compressing the images.

Anyway: Many thanks for the quick explanation!!!
Thanks, just went and fixed the glossary.
Reference URL's