MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - browser dropdown issue in private instance

WebPagetest Forums

Full Version: browser dropdown issue in private instance
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Having an issue with chrome not appearing in my browser drop-down list in my newly built private instance. IE appears and testing is working properly but no matter what I have tried I cannot get chrome to appear. Other updates made to locations.ini are reflected.

As I have read from previous posts the browser dropdown is entirely dependent upon the locations.ini file which I believe is configured properly.

Here are the contents of my locations.ini:


label=New York Office

browser=IE 9
label="Internet Explorer 9"

browser=Chrome 11
label="Chrome 11"

Any thoughts on troubleshooting or solutions are greatly appreciated. Not seeing any errors being reported which is making this more problematic to isolate and resolve.

Thanks all.
Do you have wptdriver.exe running on the test machine? The browser/location will automatically be hidden on the server if the test agent hasn't connected within the last hour.
Yes wptdriver.exe is running on the test machine but if the server is dynamically detecting availability that does give me another place to look for issues.

Here is the contents of my wptdriver.ini:


options="--load-extension=%WPTDIR%\extension --user-data-dir=%WPTDIR%\chrome_cache --new-window --no-proxy-server --no-first-run --no-default-browser-check"
Check the access log on the server to make sure it shows work/getwork.php requests for the location Test_Chrome - that will help rule that out.
Was just about to post this up when you replied:

GET /work/getwork.php?location=Test_Chrome&key=TestKey123&software=wpt&ver=11&pc=NYNYCWEBTEST03 HTTP/1.1" 200 377 "-" "WebPagetest Driver

This is a windows 7 vm that is only being configured for wptdriver and chrome if that helps clarify at all.

Thanks for all the replies and assistance!
Hmm, ok, now you have me stumped. Is there a tmp directory on the server (under the web root) with and files in it?

Can you check to see if it shows up in the list there?

It doesn't look like the agent is an issue but as a side note (in case it wasn't obvious in the directions), you can install wptdriver and urlblast on the same VM and have them both running at the same time. They have protections to make sure that only one of them will be executing tests at a given time but it lets you get better utilization of your systems.


As part of my testing before posting I tried configuring chrome on the same vm as the working IE instance and encountered the same issue.

Anywho, I have tested getTesters.php and the chrome machine is listed:

Test_Chrome (0 minutes)
Tester Version PC EC2 Instance IP Busy? Last Check (minutes) Last Work (minutes)

Additionally both and are present in the tmp directory.

Seems like I am encountering a curious situation...will keep at it and let me know if you have any thoughts or further suggestions and I'll post back if I make any further progress.

Thanks again for being so responsive.
Hmm, might have to add some logging to figure out what is going on. Any chance you can zip up your server document directory and zend it to me at I can run it through a debugger and should be able to figure it out pretty quickly.
Sent it to you via google docs...let me know if you have any problems receiving or accessing.

Thanks again for all the help
so no luck resolving my issue with 2.3 but I can confirm that the dropdown list behaves as expected under 2.2.

Will have to look more at the differences between the 2.2 and 2.3 releases.
Pages: 1 2
Reference URL's