MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Waterfalls not showing up in results directory

WebPagetest Forums

Full Version: Waterfalls not showing up in results directory
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I apologize if this is posted elsewhere, I have not been able to find an answer.

I have WPT 2.12 installed on Windows XP with Apache 2.2.25 and PHP 5.4.21. When I run tests, the waterfall shows properly, but when I look in the results folder, I do not see it. Yes, GD is installed properly (as far as I can tell).

Here is the result of install/index.php

WebPagetest Installation Check
PHP
PHP version at least 5.3: 5.4.21
GD Module Installed: yes
zip Module Installed: yes
zlib Module Installed: yes
curl Module Installed: yes
APC Installed: NO (optional)
ffmpeg Installed (required for video): yes
jpegtran Installed (required for JPEG Analysis): yes
exiftool Installed (required for JPEG Analysis): yes
php.ini upload_max_filesize > 10MB: 20M
php.ini post_max_size > 10MB: 20M
Filesystem Permissions

{docroot}/tmp writable: yes
{docroot}/results writable: yes
{docroot}/work/jobs writable: yes
{docroot}/work/video writable: yes
{docroot}/logs writable: yes
Test Locations

Video rendering is supported

Test_loc : San Bruno, CA
IE : Test Location - IE 8 - 1 agents connected
Test : Test Location - 1 agents connected[/size][/size]

And these are the files I see in the results directory:
1_devtools.json.gz
1_IEWPG.txt.gz
1_IEWTR.txt.gz
1_progress.csv.gz
1_report.txt.gz
1_screen.jpg
1_screen.png
1_screen_doc.jpg
1_screen_render.jpg
devToolsProgress.json.gz
test.job
testinfo.ini
testinfo.json.gz

Any help is greatly appreciated!
The waterfalls are generated dynamically by PHP and returned directly to the browser - they are never stored on disk. If you want the images you should request them through the API interface.
Thank you very much for your response. I should have mentioned initially that I am using the API, using the test URL, the images portion of XML payload I get back from a test looks something like the following, but the URL to the waterfall does not work.

<images>
<waterfall>
http://foo/results/13/11/06/DG/20/1_waterfall.png
</waterfall>

<connectionView>
http://foo/results/13/11/06/DG/20/1_connection.png
</connectionView>
<checklist>
http://foo/results/13/11/06/DG/20/1_optimization.png
</checklist>
<screenShot>
http://foo/results/13/11/06/DG/20/1_screen.jpg
</screenShot>
<screenShotPng>
http://foo/results/13/11/06/DG/20/1_screen.png
</screenShotPng>
</images>

I currently have code that utilizes the public instance and the links to waterfalls in the xml are valid. I am updating the URLs in the code to use the new private instance, but I am hitting this roadblock.
Do you have mod_rewrite enabled? Those are the "friendly" version of the URLs that get rewritten to point to waterfall.php with query params. It should be auto detecting the lack of mod_rewrite and giving you the direct URLs when it isn't present but that doesn't always happen.
(11-06-2013 09:50 PM)pmeenan Wrote: [ -> ]Do you have mod_rewrite enabled? Those are the "friendly" version of the URLs that get rewritten to point to waterfall.php with query params. It should be auto detecting the lack of mod_rewrite and giving you the direct URLs when it isn't present but that doesn't always happen.

Thanks for the suggestion. I checked httpd.conf and the module is un-commented.

LoadModule rewrite_module modules/mod_rewrite.so
I'm seeing this same issue. I also have mod_rewrite enabled.

Where are you doing the rewrites? Maybe i missed a part of the install.

Do you have anything special in your httpd.conf or php.conf file for apache?
(11-07-2013 04:30 AM)mlamanuzzi Wrote: [ -> ]
(11-06-2013 09:50 PM)pmeenan Wrote: [ -> ]Do you have mod_rewrite enabled? Those are the "friendly" version of the URLs that get rewritten to point to waterfall.php with query params. It should be auto detecting the lack of mod_rewrite and giving you the direct URLs when it isn't present but that doesn't always happen.

Thanks for the suggestion. I checked httpd.conf and the module is un-commented.

LoadModule rewrite_module modules/mod_rewrite.so

Make sure you have the .htaccess file. For some reason, i didn't have it. That's where all the rewrites live. I found it on github.

https://github.com/WPO-Foundation/webpag...master/www
Reference URL's