MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - errors

WebPagetest Forums

Full Version: errors
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi! I have some problem with
Quote:root@ubuntu:/home/ubuntu/webpagetest/batchtool# ./ --runs=1 --connectivity=custom --bwup=384 --bwdown=1500 --latency=100 --plr=1 --server http://my.server/
WARNING:root:URL submission failed:
WARNING:root:URL submission failed:
WARNING:root:URL submission failed:
What did it mean?
I need allow those URLs somewhere on the server?
You probably need to specify a location as well.
(12-04-2013 06:43 AM)pmeenan Wrote: [ -> ]You probably need to specify a location as well.

Thank you, Patrick.
I really made ​​a mistake in the location, it was necessary to use location from instance config, not the one that is displayed in the web interface.
Im having this same problem and have tried specifying various locations to no avail: -s -r 2 -o us-east-1_IE8 -s -r 2 -o us-east-1:Chrome -s -r 2 -o us-east-1 -s -r 2 -o us-east-1-group -s -r 2 -o ami-561cb13e -s -r 2 -o Dulles -s -r 2 -o Dulles:Chrome -s -r 2 -o us-west-2b

I also tried using the External IP of the AMI.

What is the correct format for the location names?

Not sure if this is related but if i just run with no params I get the following (I can ping names and resolve ok from the cli) I have set the Python version to be 2.7 as 2.6 doesnt appear to be there:

Traceback (most recent call last):
File "./", line 206, in <module>
File "./", line 203, in main
File "./", line 103, in RunBatch
File "/var/www/webpagetest/batchtool/", line 71, in SubmitBatch
response = __LoadEntity(request, urlopen)
File "/var/www/webpagetest/batchtool/", line 31, in __LoadEntity
response = urlopen(url)
File "/usr/lib/python2.7/", line 87, in urlopen
File "/usr/lib/python2.7/", line 208, in open
return getattr(self, name)(url)
File "/usr/lib/python2.7/", line 345, in open_http
File "/usr/lib/python2.7/", line 969, in endheaders
File "/usr/lib/python2.7/", line 829, in _send_output
File "/usr/lib/python2.7/", line 791, in send
File "/usr/lib/python2.7/", line 772, in connect
self.timeout, self.source_address)
File "/usr/lib/python2.7/", line 553, in create_connection
for res in getaddrinfo(host, port, 0, SOCK_STREAM):
IOError: [Errno socket error] [Errno -2] Name or service not known
Check - it should give you a list of the locations that you configured (it is whatever you put in locations.ini).
Reference URL's