MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - domElement

WebPagetest Forums

Full Version: domElement
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Can someone provide some info regarding the domElement setting. Doc says

domelement- DOM Element to record for sub-measurement

Does it alter the time reported from document complete or is its render time reported someplace I haven't found in the GUI? It sounds like exactly what I would like.
It dhouldn't change any other times, it should just report the time when that element was added to the DOM and it should show up as a "DOM Time" in the GUI (for the desktop browsers anywy, not supported on mobile).
(05-22-2014 11:57 PM)pmeenan Wrote: [ -> ]It dhouldn't change any other times, it should just report the time when that element was added to the DOM and it should show up as a "DOM Time" in the GUI (for the desktop browsers anywy, not supported on mobile).

Pat, Sorry to be slow about this but where exactly does this show up? I was looking for a line on the waterfall or an extra column in the table near the top.

Perhaps I'm entering the domElement in the wrong format.

With the google image specified
http://www.webpagetest.org/result/140522_9J_TKR/
Without
http://www.webpagetest.org/result/140522_P2_TQP/

I do see the "Result (error code)" is non zero when I specified the domElement.

Thanks again for your patience.
Sorry, may be an issue with the Chrome implementation. If you try IE 8 or 9 you should see it like this: http://www.webpagetest.org/result/140522...0e489ca4e/

I used to have an info link explaining the format but that appears to be gone. It uses the same format as the scripting for identifying the DOM element: https://sites.google.com/a/webpagetest.o.../scripting

Basically:
id=hplogo
Reference URL's