WebPagetest Forums

Full Version: issues with WPTDriver and empty results
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Patrick,
I was trying to install the Private instance with WPTdriver for Chrome.
copied my wptdriver.ini and locations.ini tot his thread.

path for wpt-www : C:\Apache24\htdocs\wpt-www
path for agent: C:\wpt-agent

When i try to run the tests,it starts and keeps on testing for ever and doesn't launch Chrome browser or provide any errors or results.
I did check the jobs and it is being created in the work folder under Test.

Also,attached install snapshot and Dummynet snapshot.

==================================
Locations.ini

[locations]
1=Test_loc
;2=Public_Dulles
default=Test_loc

;
; These are the top-level locations that are listed in the location dropdown
; Each one points to one or more browser configurations
;

[Test_loc]
1=Test
;2=IE
label=Test Location

;
; Tese are the browser-specific configurations that match the configurations
; defined in the top-level locations. Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)
;
;[IE]
;browser=IE 11
;latency=0
;label="Local - IE 11"
;browserExe=pagetest.exe
;key=TestKey123


;
; For a wptdriver configuration (chrome, firefox), the browser labels here
; MUST match the labels used in wptdriver.ini
;

[Test]
browser=Chrome
latency=0
label="Test Location"
localDir="C:\Apache24\htdocs\wpt-www\work"
key=TestKey123

;
; This is an exaple of a "remote" configuration where tests can be proxied to a remote
; webpagetest instance. The test will be run by the remote server but the results


==============================================
wptdriver.ini
[WebPagetest]
url=http://127.0.0.1
location=Test
browser=Chrome
Time Limit=300
key=TestKey123
;Automatically install and update support software (Flash, Silverlight, etc)
;software=http://www.webpagetest.org/installers/software.dat
debug=1

[Chrome]
exe="C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'
;installer=http://www.webpagetest.org/installers/browsers/chrome.dat
key=TestKey123
=====================================================

(05-21-2014 11:27 AM)chicagorajesh Wrote: [ -> ]Patrick,
I was trying to install the Private instance with WPTdriver for Chrome.
copied my wptdriver.ini and locations.ini tot his thread.

path for wpt-www : C:\Apache24\htdocs\wpt-www
path for agent: C:\wpt-agent

When i try to run the tests,it starts and keeps on testing for ever and doesn't launch Chrome browser or provide any errors or results.
I did check the jobs and it is being created in the work folder under Test.

Also,attached install snapshot and Dummynet snapshot.

==================================
Locations.ini

[locations]
1=Test_loc
;2=Public_Dulles
default=Test_loc

;
; These are the top-level locations that are listed in the location dropdown
; Each one points to one or more browser configurations
;

[Test_loc]
1=Test
;2=IE
label=Test Location

;
; Tese are the browser-specific configurations that match the configurations
; defined in the top-level locations. Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)
;
;[IE]
;browser=IE 11
;latency=0
;label="Local - IE 11"
;browserExe=pagetest.exe
;key=TestKey123


;
; For a wptdriver configuration (chrome, firefox), the browser labels here
; MUST match the labels used in wptdriver.ini
;

[Test]
browser=Chrome
latency=0
label="Test Location"
localDir="C:\Apache24\htdocs\wpt-www\work"
key=TestKey123

;
; This is an exaple of a "remote" configuration where tests can be proxied to a remote
; webpagetest instance. The test will be run by the remote server but the results


==============================================
wptdriver.ini
[WebPagetest]
url=http://127.0.0.1
location=Test
browser=Chrome
Time Limit=300
key=TestKey123
;Automatically install and update support software (Flash, Silverlight, etc)
;software=http://www.webpagetest.org/installers/software.dat
debug=1

[Chrome]
exe="C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'
;installer=http://www.webpagetest.org/installers/browsers/chrome.dat
key=TestKey123
=====================================================

Also my machine is 64 bit Windows 7
It looks like the agent is connected. Can you delete the localDir entry from your locations.ini? It isn't necessary - don't think it will cause issues but it might.

Does the work/jobs/Test/<testID>.url job file get created and then deleted or does it stay there?
Patrick,

Thanks for your response. I was able to fix all the errors for execution.
HAd some issues with Dummynet so updated my locations.ini with connectivity=lan and now it opens up Chrome and completes the test.

fAcing the following issues
WPTdriver shows - waiting for 600 seconds to complete this job.
No results were displayed and after timeout it shows " No test results available"

I was able to see the test.json file created in the results folder.

Please let me know where i making mistake.

Thanks
Rajesh
Do you see requests in your access log for /work/resultimage.php and /work/workdone.php?
(05-28-2014 12:35 AM)pmeenan Wrote: [ -> ]Do you see requests in your access log for /work/resultimage.php and /work/workdone.php?

Patrick,

I was able to see the results for few tests after 10 mins.I changed the Timeout to 60 secs in the wptdriver.ini but no luck.

The test runs succesfully in Chrome ,closes up but the access file still shows teststatus.php and couldnt see the /work/resultimage.php and /work/workdone.php.

Do you think is it bcoz of %Profile% issue?
Currently,it is set to Allusersprofile = C:\ProgramData

is it rite? Am i making any mistakes?
Do you see calls to getwork.php? It shouldn't be a profile issue but it's hard to say. I just want to see if the agent is talking to the server correctly first (and that you can see that traffic in the access logs).
Reference URL's