WebPagetest Forums

Full Version: Problems with Server and Agents talking to each other on EC2
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey,

I've been setting up a private instance of WPT on AWS EC2's.

I've set the server up on an ubuntu t1.micro. This looks to be setup correctly as I can reach the home page.

The problem is the test location/browser drop down's are not populated.

I've edited the locations.ini file to look like the following:

Code:
[locations]
1=EU_W
default=EU_W

;
; ****** Ireland *****
;

[EU_W]
1=EU_WEST
2=EU_WEST_wptdriver
label="Europe (Ireland)"
lat=53.343583
lng=-6.267014
default=EU_WEST

[EU_WEST]
; AMI: ami-33b98747
; user-data: wpt_server=wpt.example.co.uk wpt_key=SecretKey wpt_location=EU_WEST
browser=IE 9
latency=0
label="Europe (Ireland) - IE9"
key=SecretKey

[EU_WEST_wptdriver]
; uses same instance as EU_WEST (make sure the SecretKey is the same for both)
browser=Chrome,Firefox
latency=0
label="Europe (Ireland)"
key=SecretKey

I've install the agent from the AMI with the user data:
Code:
wpt_server=wpt.example.co.uk wpt_key=SecretKey wpt_location=EU_WEST

Reading the instructions. I believe the Agent needs to poll the Server before the locations display?

Do I need to apply any special inbound/outbound settings to the security group of either. At the moment I have added The default SSH for the server, RDP for the Agent and HTTP/HTTPS inbound for the server.

Any help pointing out where I have gone wrong would be appreciated.
Did you replace wpt.example.co.uk with your actual server name? (you probably also want to change the secret key in both userData and in locations.ini).

The agents poll the server over http so as long as you can access the web UI it should be fine.
(06-10-2014 12:35 AM)pmeenan Wrote: [ -> ]Did you replace wpt.example.co.uk with your actual server name? (you probably also want to change the secret key in both userData and in locations.ini).

The agents poll the server over http so as long as you can access the web UI it should be fine.

Patrick,

is the secret key required? I'm seeing the same issue on our private instance. I set the proper server name on both user data and locations.ini but i did not set the secret key user data.
No, but if you have it defined on the server then the key on the agent needs to match. If you don't set it in user data then you need to make sure it isn't defined in the location definition in locations.ini
Reference URL's