MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - video rendering and wptdriver

WebPagetest Forums

Full Version: video rendering and wptdriver
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Is video rendering performed only by urlblast.exe?

I have only wptdriver agents and until I start urlblast.exe, videos are not rendered and I get information that no agent is capable of rendering videos on "WebPagetest Installation Check" page.
For the moment, yes it is.

Pat's working on moving the logic to the server.
I literally just landed the bulk of the code over the last 2 days and should have it polished and ready today or tomorrow.

If you watch this bug I'll close it as soon as the last code bits are verified and pushed: https://github.com/WPO-Foundation/webpagetest/issues/25
Just pushed the code and it's also live on webpagetest.org. It also includes a lot of improvements over the urlblast rendering:

- Supports the 60fps video from mobile
- Much better layout grids for mobile (and generally better for desktop as well)
- Supports insanely-large grids (I tested up to 150 tests being compared)
- Fixes all sorts of playback issues in the embedded player (creates real 30/60fps video not 10fps)
- Added a margin at the bottom so the embedded player progress bar doesn't overlap the timers

If you don't want all of the code from trunk it is nicely isolated and you just need:
video/create.php
video/render.php
video/font/*
I usually update to latest revision.

Works perfectly now.

Thanks, Patrick!
Reference URL's