WebPagetest Forums

Full Version: Test completed, but no waterfall displayed and no requests information
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi,

I have problem with some of my agents. I tried to reinstall them but problem persists on some machines.

All metrics are present in test results but request list is empty and as a result waterfall is not displayed.

I did some investigation and found that 1_IEWTR.txt.gz file is not present in test results.

Example of the test results is available here: https://www.dropbox.com/s/fa4rmbyhjzy1si....tgz?dl=0.

I use wptdriver version 190 and HEAD version of WPTServer.

How can I diagnose what problems wptdriver faces? Is it possible to activate any debugging and logging?
I've just checked that urlblast works correctly at the same machine.
You can grab a debug build here: http://www.webpagetest.org/releases/debug/ and then run debugView ( http://technet.microsoft.com/en-us/sysin...96647.aspx ) to get a detailed trace. (run it as an administrator and enable global capture).

Do you see issues for non-SSL sites as well?
Thanks, I will try it tomorrow.

Yes, it happens to any test I run on these particular machines. I do not have control on how OS is installed on them so I cannot correlate this problem to anything I know.
Seems that debug version upgrades itself to the newest, not debug (190).

Is it OK?

Is debug version 190 of wptdiver available?
I just pushed release and debug versions of 192 though it's probably easiest for your debugging if you just disable updates on your server (rename work/update/wptupdate.ini) while you're debugging.
Hi,

Finally I managed to collect debug log from the test with no waterfall data.

I cannot find anything from it that can help to solve this problem unfortunately.
Patrick, are you able to find anything obvious in logs attached? Apparently something is being automatically deployed on my agent workstatnions one by one and all my test environment gradually becomes useless.
Sorry, I've been traveling (getting back tonight) and haven't had a chance to look yet.

I just took a quick look and it looks like all the pieces are hooked up and working so it's not clear where it is broken. I may have to send you a debug build with more tracing (the winsock hooks don't log any data by default and the end of the test doesn't log anything about the requests it sees).

I'll work on the added tracing on my flight back but in the meantime does your update history show anything that might be suspicious? Browser, Antivirus, EMET or other updates?
It is really hard for me to get any information about what and when was updated. Machines I use for running wpt agents are provided to me as a courtesy of remote branches of company I work for. I would like to avoid asking them embarrassing questions Wink

I think that debugging this problem can have added value for further development of WPT.

Thanks Patrick for your help!

Best regards,
Pages: 1 2
Reference URL's