WebPagetest Forums

Full Version: Speed Index
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi is it possible to capture speed index in a private instance of webpage test and if so what version? And if not can you calculate it somehow?
I've got a private instance of WebPageTest and it generates a speed index value for each test without a problem.
The public and private instances all use the same code and Speed Index has been there for at least 2 years. The only thing you should need to do is to make sure that video capture is enabled for your tests because it is needed for Speed Index.
(11-25-2014 04:10 AM)pmeenan Wrote: [ -> ]The public and private instances all use the same code and Speed Index has been there for at least 2 years. The only thing you should need to do is to make sure that video capture is enabled for your tests because it is needed for Speed Index.

Thanks for the reply I have it all working now, out of interest does the api capture speed index?
Yep, just make sure to pass video=1 to enable video capture (at some point I'll make it calculate speed index even without uploading video).

The UI is layered on top of the same API so anything you can do in the UI can be done through the API.
I remember having to dig around to find the link between enabling video and calculating speed index for API calls. It would be helpful to update the API docs - https://sites.google.com/a/webpagetest.o...stful-apis - to indicate that ( at least until that changes ).

Could be something as simple as changing the video line from:

"video optional Set to 1 to capture video"

to:

"video optional Set to 1 to capture video. This is required in order to get a speed index value"
Reference URL's