WebPagetest Forums

Full Version: WPT close all Browsers after Test completed
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

my problem is, that after a Test finish all Browser all Browsers were closed.

Here my wptdriver.ini:
Code:
[WebPagetest]
url=http://127.0.0.1/
location=Local-WPTDriver
browser=chrome
Time Limit=120

[chrome]
exe="C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'
;installer=http://www.webpagetest.org/installers/browsers/chrome.dat

[Firefox]
exe="C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
options='-profile "%PROFILE%" -no-remote'
;installer=http://www.webpagetest.org/installers/browsers/firefox.dat
template=firefox

[IE]
exe="C:\Program Files\Internet Explorer\iexplore.exe"
location.ini:
Code:
[locations]
1=Local
default=Local

[Local]
1=Local-URLBlast
2=Local-WPTDriver
label=Local

[Local-URLBlast]
browser=IE 11
latency=0
label="Local - IE 11"
connectivity=LAN
;browserExe=pagetest.exe
;key=TestKey123

[Local-WPTDriver]
browser=Chrome,Firefox
latency=0
label="Local"
connectivity=LAN

Any ideas why this happens?

Best regards
demin
I haven't watched a test live for a while but I'm pretty sure it's default behaviour to close all the configured browsers when a test completes.
Correct. It is expecting to run on a dedicated test machine or VM and that is part of the cleanup to make sure no stray processes are left running. If you want to test locally you should be able to use a different browser than what is being used for the test and it should stay up (using IE when running Chrome tests for example).
Reference URL's