MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Win 7 - Failed to configure IPFW/dummynet. Is it installed?

WebPagetest Forums

Full Version: Win 7 - Failed to configure IPFW/dummynet. Is it installed?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a virtual Win 7 32 bit PC with a vmxnet3 NIC. The ipfw+dummynet driver installed. Running ipfw.cmd in a command prompt shows no error (see attachment), wptdriver.exe drivers starts and waits for work.
Any test I run gets the error - The testing completed but failed. Failed to configure IPFW/dummynet. Is it installed?

wptdriver.ini is configured as follows;
Time Limit=120
Automatically install and update support software (Flash, Silverlight, etc)

exe="C:\Program Files\Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'

exe="%PROGRAM_FILES%\Mozilla Firefox\firefox.exe"
options='-profile "%PROFILE%" -no-remote'


;exe="%PROGRAM_FILES%\Internet Explorer\iexplore.exe"

locations.ini server is as follows:

; These are the top-level locations that are listed in the location dropdown
; Each one points to one or more browser configurations
label="File System Win 7"

;label=" - Dulles, VA"

; Tese are the browser-specific configurations that match the configurations
; defined in the top-level locations. Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)

;browser=IE 8
;label="Test Location - IE 8"

; For a wptdriver configuration (chrome, firefox), the browser labels here
; MUST match the labels used in wptdriver.ini
label="File System Win 7"

Any suggestions? Many thanks
What build of wptdriver? There were changes made a few months ago that hopefully made it more robust and have it call out to ipfw.exe directly (previously on 32-bit systems it used to talk to the driver directly).
The details on wptdriver.exe show file & product version
Tried the latest 2.18 release, unfortunately no change on the error
I was also having a similar issue until i figured I had to copy the files from the 32 or 64 bit folder to the C:\WPT\agent\dummynet folder.
Reference URL's