MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - No 'Access-Control-Allow-Origin' header is present on the requested resource

WebPagetest Forums

Full Version: No 'Access-Control-Allow-Origin' header is present on the requested resource
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there, I've just done a speedtest overhere at http://www.webpagetest.org/result/150806_6X_TGW/

The test seems to work fine, and also return values I might expect.
However, the screenshots at http://www.webpagetest.org/result/150806...reen_shot/ don't seem to work. There's an error saying

"XMLHttpRequest cannot load http://static.telefoonabonnement.nl/css/...s.min.css. No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://www.telefoonabonnement.nl' is therefore not allowed access."

What's going on here? Is this a bug in WPT? Or is there something wrong with my sites' scripting?
The blank screen shots are a problem with the WPT agent in Netherlands - apparently it needs a reboot (I'll see if I have access to it).

The console errors are from the page that was tested, not WebPageTest itself. If you use Chrome and open up dev tools (F12) and browse the page you should see the same warning. It is telling you that some code on the page failed to do what it tried because the request was blocked by Chrome (static. is a different domain from www. and the Ajax code isn't allowed to talk to it - CORS).
Reference URL's