MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Annoying crx calls with Chrome

WebPagetest Forums

Full Version: Annoying crx calls with Chrome
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

When testing with Chrome, I found annoying *.crx calls in waterfalls.
I've tried to block them but without success.

It seems to be chrome extension updates.

Is there a way to eliminate them ?

Thx


call #1

URL: http://redirector.gvt1.com/crx/blobs/QgA..._1_2_0.crx
Host: redirector.gvt1.com
IP: 216.58.208.238
Error/Status Code: 302
Client Port: 1708
Start Offset: 0.732 s
Time to First Byte: 79 ms
Content Download: ms
Bytes In (downloaded): 1.5 KB
Bytes Out (uploaded): 0.5 KB

Call #2

URL: http://r20---sn-25g7sm76.gvt1.com/crx/bl...0&key=cms1
Host: r20---sn-25g7sm76.gvt1.com
IP: 208.117.236.153
Error/Status Code: 200
Client Port: 1733
Start Offset: 0.931 s
DNS Lookup: 59 ms
Initial Connection: 59 ms
Time to First Byte: 115 ms
Content Download: 3371 ms
Bytes In (downloaded): 179.0 KB
Bytes Out (uploaded): 0.7 KB
Private instance or here on the public instance? I've been playing whack-a-mole with the extension updates and recent agent updates should have them blocked but if not it would help to see a failure so I can add more blocking to the agents.
I'm seeing this issue with Chrome from the Manchester instance at the moment. It's skewing a lot of stats.
ok, I just pushed an update that expanded the blocking and that appears to have fixed it. Let me know if you see any more crx downloads sneak in.
Hey Patrick it seems like it came back. Happening on different sites I am testing, but here is a good example: https://webpagetest.org/result/200411_HR...p1_request

Any solution planned?

Thanks,

John
Sorry, there was a change made over the weekend to show requests where the connection failed (for SPOF, etc). It looks like that also accidentally picked up showing the blocked Chrome requests.

I just made a change to filter those out of the reporting. It'll take about an hour for it to roll out but they should be gone after that.
Actually, that's just the clienst1.google.com requests. Looking into what is going on with the other ones now.
Reference URL's