WebPagetest Forums

Full Version: Allow Location Dialog In Chrome
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Some pages of a website I use recently switched to geolocating. This change caused the "Website wants to: Know your location" Chrome dialog. This causes the page to render incorrectly since the popup is not interacted with.

How can I tell WPT to always allow location?

I am using:
AMI: IE11/Chrome/Firefox/Safari (2014, wptdriver only) - ami-561cb13e.
Chrome: Version 47.0.2526.106 m


I attempted 2 fixes, and neither worked:
1. Manually confirm the dialog, but it reappears on next run.
2. "Allow all sites to track your physical location" in Chrome settings. This also did not stop the dialog from appearing.
I can make WPT load a different chrome profile as a workaround, but I am still looking for a simpler solution if anyone has one. Thanks.
I am running into this same issue just running tests on the public webpagetest.org. Is there a script or request that can be blocked to prevent this popup from coming up on mobile tests? It's throwing the speed index metrics all out of whack because it's recognizing the last frame as the visual completion of the page, which is the location dialog overlayed a grayed out page.
Do you have a test example? At least for Chrome the geo-location prompt should be disabled. Here is a test for example: https://www.webpagetest.org/result/18032...98e42a2b3/
(03-22-2018 01:19 AM)pmeenan Wrote: [ -> ]Do you have a test example? At least for Chrome the geo-location prompt should be disabled. Here is a test for example: https://www.webpagetest.org/result/18032...98e42a2b3/

https://www.webpagetest.org/result/18041...af7a2c8a0/

If you open up the Filmstrip View, you can see how the last frame is throwing off the visual completion % for the whole load.
Ahh, thanks - looks like the prefs aren't being populated on the physical devices, just the desktop browser. I'll take a look and see if it can be done.
Reference URL's